Cubase 10.5 Can't erase pitch bend events?

Hey, sanity check guys
Is it just my installation of Cubase 10.5 or has anyone seen an issue where the erase tool isn’t removing selected pitch bend events?

I just want some feedback before presuming this is a bug introduced in 10.5 and reporting it.



What editor are you talking about, please?

I have tried this in the Key Editor and it works to me here.

The audio event editor. When you double-click on an audio event and get the editor window in the bottom area where the mixer channels are.
After playing around with it a bit I was able to erase the pitch bend data but it took quite a bit of time clicking in and around the same point before it got erased.

Selecting an entire section of the bend data and attempting to use the erase tool did nothing though.

It could be my system but it was working before the upgrade. Still I don’t want to just assume it to be a bug. Maybe I need to remove and reinstall???


I’m sorry, but there is no Pitch Bend MIDI data on an Audio Event.

Maybe screenshot could help.

Not at my system right now but you are correct, I mistakenly made reference to the Audio Event. I meant double-clicking on the MIDI Event to get the MIDI Event editor on the bottom pane. Not the Audio Event.

Recording a bar or 2 of midi data and using the pitch bend controller during the recording
Double-click the MIDI Event to get the MIDI Event editor on the bottom portion of the window
Filter the event to show pitch bend data only
Select the entire range of the pitch bend data and try to use the erase tool

Sorry I wasn’t more clear and accurate describing the issue the first time :frowning:


Once the Pitch Bend data is selected, you can hit Delete or Backspace key to delete it. But the Erase tool should work too, of course. Make sure you know, which of the corners is the active one. It’s the right-bottom one.

Thanks Martin.

The Delete works but I’m still having issue with the erase tool so it must be my installation. I don’t know why but seems anytime I upgrade from an prior version I always seem to get these weird issues.

Gonna remove everything and install from scratch. That has usually fixed things in the past and at least I know it’s not a bug. :smiley:


Are you aware you have to click to one of the event, even if the selection has been done?

Yep, I am. It works but I have to click on the event several times before it actually deletes it. I didn’t have the issue before the upgrade.

And I recently noted after my last response that I also have a VST plugin that shows up in the Plugin Manager as installed but isn’t available in the list of VST instruments. Checked the same VST plying installed on another system running Cubase and there’s no issue and the VST shows up without issue. So I’m totally convinced that there’s something flawed in the installation.

Thanks for clarifying things


Do you use common mouse? Or Apply MagicMouse or something like this? Or a touch-screen? This could cause these “click” problem.

Maybe you could try in Cubase Safe Start Mode.

I am using the Magic Mouse that came with the system. I removed and re-installed Cubase and the issue seems to have “somewhat” resolved. It still isn’t as easy to click a point within the pitch bend event or even select a section and use the erase tool and have it remove the events on the first attempt.

But it seems to take fewer attempts to get it to work. And one of my VST instruments still isn’t available to select though it’s registered and visible within the Plugin Manager but at this point I’m not going to make a big deal of it. I can delete the events, it just doesn’t function as quick and easy as it was when I was on Cubase 10.

The VST plugin problem is altogether a different issue, but I’m suspecting after a few updates and hotfixes to 10.5 things will iron themselves out. And it isn’t killing me not to have the VST instrument available. I can live with it.

I tried launching in Safe mode pressing Shift+Option+Command but I just get an Open Document dialog where I have to select one of the projects to open. That’s not the screen I’m used to seeing but maybe that too changed with 10.5???


Then you hold it down to late. Hold the Shift+Option+Command down immediately after double-click icon.