Cubase 10.5: can't solve crazy real-time peak

well what is running in the background
is it a laptop ?
is this an audio PC - or used for games/internet ?
what have you done to ‘optimise it’ ?

Thanks so much for that tip about the Nvidia MSI registry hack!

Also found another article, with a good howto (also an entertaining read):

I’ve just applied it to my system and rebooted, since it seems like there’s only upside to it.

Thanks again - much appreciated!!!

1 Like

it normally makes latencymon look much better :slight_smile: - although the problems kinda move elsewhere…but it’s 100% worth doing on nvidia cards. And normally 100% helps

Alex’s problem is something else though :slight_smile:

2 Likes

@Dr.Strangelove
that’s the thing with problems - they keep moving! :rofl:

Yeah - I think you’re right - Alex’s is a different puzzle …

It’s an audio pc basically. I’ve done most “usual” optimizations, like disabling unneeded services, background apps etc. there are probably a few things more I could do, but I’m not sure they’ll make any substantial difference. Is there something you’d suggest?

have you disabled c-states and set it to turbo mode in the bios ?
changed to the ‘steinberg power plan’ or created your own max-power plan ?
checked what’s in the startup apps section ?

and disable that soundblaster in the bios !

again - these might not fix the problem but are definitely worth doing

and I assume, you’re pretty sure that Alex’s problem is on the hardware/driver levels - not something like ASIO Guard?

when you input-monitor ASIO guard is switched off on that track - that’s why the performance meter goes up when he selects it - means it’s working properly

could be lots of things - might be a bad network card driver ? dodgy bios ?

might as well eliminate the stuff you should do anyway and take it from there - low hanging fruit.

FWIW - I’ve a fairly expensive Dell laptop here - impossible to get decent latency numbers on it - the bios is too buggy - or badly written. Was lots of complaints at the time, went all the way to Frank Azor who was head of Alienware (dell) at the time - they promised to fix it for months but couldn’t …nothing that the user could do to fix that…it was as the bios level.

2 Likes

on some systems in the past, I’ve had grief from mobo wifi, so now I’m always running Ethernet

1 Like

yes - wifi can be dodgy too - cable is always better IMO - intel are normally pretty good - but even then there are things you can try such as Moderation Rate

So, yes I’ve already done the following and problem’s still there:

  • disabled c-states
  • tried Steinberg power scheme (using “high performance” scheme otherwise)
  • checked in safe mode
  • disabled the soundblaster z
  • disabled network card entirely (I’m not using wifi)

when you run latencymon do you see the same spikes every second or so ? in ACPI.sys ?
try different usb port for the SSL interface ?
do you get the same problem using the soundblaster (with asio4all driver) ?
you may need to go through Device Manager and try disabling some things to see if it improves…it may not !

Ok, so a small update: I don’t know exactly how, but right now I’ve managed to minimize the cpu spikes almost entirely!
I heeded your advice and uninstalled almost everything not needed and also disabled some tasks/services that were redundant.

I actually think a big part of the problem was the Corsair iCue software for my keyboard. I used it mostly for macros, but I can live without them or use Autohotkey or something. As soon as iCue was uninstalled, ACPI.sys disappeared from latencymon and the high cpu spikes in Cubase are reduced from dropouts to just jumping around a bit and both meters in the performance monitor sit around 40%-50% even when monitoring 3 tracks (which is overkill for me anyway).

I can even turn off ASIO Guard now. Actually observed that I get better cpu usage with it on low or turned off, than on High. :man_shrugging:

I don’t think there’s much more to do, so I really wanna thank you guys for taking time to help me out. :heart_eyes:

1 Like

that’s great news …let us know how you get on.

Out of interest, what buffer size are you running ?

1 Like

I did some recording just a few mins ago with 64 buffer size and it didn’t drop out once.

2 Likes

amazing - I suspect you’ve probably got as good a performance as you can get out of that setup.

Thanks for reporting back - a good outcome.

2 Likes

It feels good, man :smiley:
Did some testing with a few quite heavy projects - lots of VSTs and tracks going on - and everything worked great!

I agree, it’s probably the best I can get from this setup. Thanks again! :smiley:

2 Likes

wow - I’m so happy for you!
Now back to making music!
And yes, thanks for letting us know that you’re good to go again! :+1:

1 Like