Cubase 10.5 Importing multiple files with higher sample rate doesn't convert them

Importing multiple files with higher sample rate than project’s doesn’t convert them even if checked to “Copy and convert to projects settings” in import popup window.
It didn’t work for me when I tried to import 96 kHz file to 48 kHz project, it just stretches and pitches the files down. It works properly with a single file. It even shows 96 kHz -> 48 kHz.

Same problem discovered here.

I raised an issue with Steinberg https://helpcenter.steinberg.de/hc/requests/235569

Works OK in 10.0.50 but broken in 10.5

Also affects the “Import” option with the pool.

I also noticed this issue in 10.5
Had to open v10 to import new files delivered to me by artist…
Fix it please!
:slight_smile:

We found out that if you put the preferences set to convert at import by default, Cubase 10.5 is able to convert all files on import correctly.

To use this workaround:

  1. Go to “Preferences -> Editing Options -> Audio”
    (online help: https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/preferences/preferences_editing_audio_r.html)

  2. Choose “Use Settings” in the options menu for “On Import Audio Files”

  3. Check the default action below: “Convert and Copy to Project If Needed”

  4. Hit apply

All files imported with this preference switched on will be conformed to the project´s settings correctly in 10.5

Hope it helps other Cubasers out there

Edu S.

I can confirm that the “workaround” above works.

However, it is still a bug that needs to be fixed in 10.5.

Thank you for posting this.

Same problem here, i’ll try the workaround but defenetly a bug to be fixed in 10.5

It is fixed now, thanks Steinberg!