Cubase 10.5 + UR824 - Hardware option missing in Rack

Hi all,

Just looking for suggestions/guidance.

I recently picked up the UR824 second hand and I’m loving the sound and flexibility as compared with my 2 channel interfaces. I’d been using the UR22 MKII for a year or so and have been very happy with quality and stability – so much so that I wanted to choose a Steinberg product for an 8 channel interface when I got the money together. Part of the appeal of the product for me was the hardware integration with Cubase. I’m actually a Reaper person and have been for years (started in Pro Tools) but the use of DSP for basic FX processing running in a DAW channel strip was compelling to me. I upgraded my old version of Cubase 6 LE (that came with a Zoom recorder) to 10.5 Elements the other day hoping I would get the hardware option in the rack drop down but it’s not there. I have scoured Google and this forum and it looks to have been an issue over the years with the MR816 and the the UR44/UR824.

I’ve tried uninstalling and reinstalling the driver and haven’t been able to see a hardware option in the rack. I have set to direct monitoring and filtered to all inputs so i don’t know what else to do. Should I reinstall Cubase? What order would be best – hardware drivers first or after the Cubase installation?

I have the DspMixFx app running fine so it’s not the end of the world but it would be nice to have all the integration as described as this was a big pull factor for me to purchase this particular interface and even possibly start working outside of Reaper.

Hi again,

Just bumping this one.

I have put a ticket in with support in Australia but this hasn’t been resolved yet. There’s still no ‘hardware’ available under rack and the DspMixFX app is running the show when Cubase is open. So it seems that Cubase doesn’t want to integrate with the UR824. I have tried reinstalling the drivers and other software several times and it has made no difference. Support asked if I could enable Busses in Audio Connections which I can and also thought that having a UR22 connected as well (which I use for MIDI) might be causing the problem. I have tested extensively without the UR22 connected and uninstalled/reinstalled all the software as well and that didn’t resolve things either.

The workaround in the older pages in this forum (and the official FAQ from Steinberg) suggested changing the ASIO driver in order to bring up a prompt window which you left unchecked but the 10.5 version of Cubase doesn’t provide the same prompt message anymore so I can’t replicate that workaround. It just asks you what driver you want to select.

If you are using the controlroom in cubase the hardware rack won’t be there, i guess it is the same as with the URC series.

Hey mate, thanks for replying. Appreciate it!

I have Cubase Elements 10.5 so I don’t think it relates to the Control Room feature which I believe is only available in Pro. Everything about my Cubase and UR824 setup functions perfectly but this hardware integration part is a mystery. I have all the control in the dsp mix app though.

I also never use the hardware rack because i use the CR.
But okay, maybe that works different for your interface, sorry.

Thanks man – it’s all useful info.

Just had a go at re-initializing the the app preferences as described here:

Still no Hardware option in the Rack drop down.

Support here in OZ recommend updating to Windows 10 to solve the issue. Here we go!

The upgrade from Windows 7 to Windows 10 has solved the problem. I just had to run maintenance on the soft eLicenser and also uninstall and reinstall all the drivers and tools for the UR824 after doing the upgrade. I now have Rack in the drop down.

Great ! enjoy making music.

Cheers mate – I will.