Cubase 10.5 - VST3 not working/CPU overloads - VST2 ok

Just wanted to report several problems I had since updating to Cubase 10.5.
Some of the Plugin Alliance vst3s cause serious CPU overloads while in idle. And DMG Audio Equilibrium shows huge CPU usage with only one plugin.
Both problems go away if I use the vst2 version of the plugin.

Anyone else had similar problems?

Guess I have to delete most VST3s for now and continue working with VST2. Those plugins were fine in Cubase 10.0.40 though…

PS I already did inform the plugin vendors as well. In case they might need to fix something.

I am seeing CPU spikes/overloads since 10.5 as well though I have not traced it to VST2 or VST3 yet.

I have the same problem!

I´m on OS Mojave MacBook Pro mid 2012 and after the new update to 10.5 there are several peaks and audio spikes on random VST plug-ins or FX. I have tried to set the audio buffer to a higher value without luck. I have also deactivate the ASIO guard, without luck. Sometimes random plug-ins hangs and makes Cubase non functional to click/or edit, but the track plays in the background. I have also experienced plug-ins that will not work at all, the GUI is freezing and no control or knob is able to move. Also the new cubase MultiTap delay hangs from time to time.

A lot of bugs in my opinion.

Same here. CPU spikes since v10.5 not related to project size. Simple project with five tracks brings my OC 9900K to its knees…
No probems whatsoever with v10.0.5

Only using VST3… Scheit.

Windows 10 1909
9900K 32 GB

For me, those spikes started in 10.0.50
And it just continued in 10.5
:frowning:

Same here guys,
random CPU spikes.

I’ve been getting huge CPU spikes as well… although doesn’t seem random in my case. Keeps happening at the same point in the project… then shifted everything over, and the spikes happen at the same point even when nothing is playing. Gonna have to revert to 10 again as its completely unusable in this state.

That’s it. Going back to 10.0.50.

Too much random BS going on with 10.5.

Same. 10.0.40 works fine.

same problem here on Windows 10 Machine… it started actually with the 10.0.50 Version! Some of my projects get cpu overloads and i can’t work on them anymore… when i open them on 9.5 everything works ok!

Disable “suspend VST3 plugin processing” in preferences and also set asio guard to high. It worked for me.

Unfortunately I tried bu I had no luck with this…

I’m also experiencing this. It’s really bad. Damn.

Same issue here. I currently have 10.0.50 and 10.5 installed. Is there a way to download 10.0.40?

If you remove VST3 plug-ins, does cubase automatically replace them with the VST2 versions when you re open the project?

It did for me but you should note your plugin settings on the vst3 plugin. I removed the black box hg2 vst3 plugin that was acting up and cubase automatically populated the slots with the vst2 version. However my mix sounded off and I finally figured out it was because all the knobs on the replaced vst2 plug-ins were reset. Pretty annoying.

Hmmm, yeah, nasty CPU overloads in my projects too now since upgrading. I’ve not been able to trace it down to anything in particular yet though. Using all sorts of well known stuff like Slate, Waves, NI etc, all up to date of course. It seems to get exasperated if i have a track selected/armed, though it still happens if i don’t.Hoping Steinberg are aware of this and looking into it…

Same here, average load is Maxed out, it is regardless to any specific plugin, 10.5 just eats 50% more cpu, tried all sorts of trick to see if it works, but nothing seems to be helping. Hope for a quick fix

Cubase 10.5 audio cpu overload makes this version not usable, Neundo 10 is fine , fortunate to have an option

Still having the VST3 issue on 10.5.5. Projects work perfectly fine in 10.0.30. Detailed post about it below for more visibility.

https://www.steinberg.net/forums/viewtopic.php?f=286&t=172999&p=933999#p933999