Cubase 10 pro performance issue, audio dropouts

Hi guys I finally managed to upgrade to cubase pro 10 from elements 8 and it just wont work right… audio dropouts all the time, real time peak goes red every 2 seconds… never ever happened with 8 elements, worked super smooth… so whats the deal? :confused:

Hi Morsei

There could be several. Don’t know you setup, but there are the usual suspects.

  1. Adjust buffer setting.
  2. Switch on multiprocessing.
  3. Turn on Asio guard.
  4. Are you running 44.1 Khz or 96 Khz in audio settings?
  5. Bad drivers from your your soundcard manufacturer.
  6. optimize your OS to DAW performance.
  7. Is your hardware fast enough to run Cubase 10 pro?

Hi Vital thanks for the reply ! ,

  1. I tried at 512 / 1024 / 2048, improves at higher I think… not so much tho
  2. where can I switch on ?
  3. I have it on !
  4. 44k
  5. I have latest drivers from traktor Z1 built in soundcard never had issues tho
  6. sorry didnt understand
  7. it ran perfectly in cubase 8 ! actually never ever got dropouts even in crazy projects with 120 channels and filled with pretty heavy vsts :/, its i3 8th gen, 16gb ram, and a ssd

Are you using the motherboards inbuilt soundcard? If so, I doubt that this will work with pro. 10.

I have my doubts that a i3 is not enough for Cubase 10 pro. It lacks cache and cannot process the amount of tasks that Cubase 10 pro is demanding. You ran elements before which is much less cpu demanding than pro 10.

You need to tweek your operating system to optimize it to work with a DAW. Google the topic.

You switch multiprocessing on in your VST control panel - same place you chose asio guard.

Just another thing. Have you selected the right soundcard in the studio settings?