Cubase 10 VST instruments problem with Komplete M32

Hi,
I have Cubase 10 on windows 10 and I’m trying to assisng the 8 knobs from my KM32 to the knobs of HALion Sonic SE. I’m pressing “Learn CC” on the VST setting, then turn the knob on the M32, and it doesn’t work. What’s weird is that if I assign it to the touch strip on the left, it works. Any ideas?

Hi and welcome,

As far as I know, NI Komplete keyboards are using own method of assignment.

In general, in HALion Sonic SE the 8 knobs are preassigned to the Quick Controls. Please, look at it in the Studio > Studio Setup, or read more about Quick Controls in the Operation manual, please.

Have you updated to the latest firmware on the keyboard

yes

please check these screenshots to see if theres something wrong


Hi,

When you use the MIDI CC for the Quick Control, these MIDI CCs are not passing thru to the MIDI Track. They do control (just) the Quick Controls.

If you load Halion Sonic via Komplete Kontrol wrapper/plugin then you use the NI mapping system - that’s how all the Komplete Kontrol controllers should be setup to run.

If you insert Halion Sonic directly into instrument slot in Cubase (i.e. don’t use the Komplete Kontrol wrapper) then you could use the Quick Controls and have your Komplete Kontrol set to the fixed MIDI template mode - check the manual for that, i think you press the plugin button twice on those, can’t remember. But you get 4 pages of rotary controls set to Midi CCs 14-21, 22-29, 102-109, and 110-117.

You really have to decide which approach you prefer - Komplete Kontrol is the fully integrated approach and offers the scale/arp modes and preset browsing plus shows parameters in the display and offers a better experience. But fixed MIDI gives you the option of using it as a ‘dumb’ controller - but, you get no feedback of the parameters you’re adjusting in the display, no preset browsing etc. However, it makes you less reliant on the NI wrapper - which could cause problems further down the road as updates are made to it.