Cubase 10, Windows 10 and multi-core (14+ cores)

can you pm me how to reverse what I used for Cubase 9.5.
in the previous version I had pops and clicks and very poor asio it was great for ages then a windows update and future Cubase update totally screwed everything up so I was advised to use the registry edit and the cmd edit.


my computer spec is—

windows 10 build 1803
intel core i7-5820k @3.30ghz
32gb ram
audio interface-- uad apollo twin usb

also what options within cubase 10 do you recommend i use ?do u use steinberg power scheme…etc ?
thanks

Just installed Cubase 10 on my 10-core (20-thread) on Win 10. First impression is that the new multi-threading model is indeed better! Will be playing with it more, but this is starting out positively for me. Hope these improvements will make it over to Nuendo soon too.

I just re-enabled hyperthreading on my 12-core i9 7920X and will be doing some testing. :slight_smile:

I’m on an i9 7940 (14 core 28 thread) and Cubase 10 is working great. I removed the registry fix and I’m able to turn on Hyper-threading which lets me have more plugins on my master channel and more headroom before maxing out the system. Awesome!

I haven’t tried playing with the Steinberg Power Scheme but I’m curious if it would help. Anyone have any idea about AVX BIOS settings and what is optimal for Cubase 10?

Buying a CPU with Cubase 10 in mind. would users think an intel 8700k (i7) or 9900K i9) would perform better? Is the i9 worth the leap?
I intend to buy on black Friday

ZeroZero, replied to this via PM. Can we please keep this thread about feedback? Thanks a lot - feel free to start a thread in the Computer Setup, perhaps some users have that CPU already!

i7800k cpu… speedstepping and turbo mode enabled, but C states still disabled just incase, 32 gig ram… multiprocessing enabled along with asio guard. ive been able to reduce buffer sizes to lower latency and all seems good so far, no pops or clips.
i was expecting to see te audio performance meter drop a bit. i assuming there is no link between internall processing and the meter… just thought there would be a show???.

Fabio (and interested others), I’m posting a link to a new thread I started regrading Windows 7 64bit and my issues with very problematic multi core usage of my 6950x (10 core) and Cubase 10. Cubase 9.5 worked perfectly.

https://www.steinberg.net/forums/viewtopic.php?f=286&t=147780&p=794536#p794536

Just some feedback - I have an 8 core HT 7820X o/c to static 4.3ghz in W10 Pro. On paper my performance should have increased 12.5% in a jump from 7 cores to 8, and in practice I think that’s pretty plausible. I have one especially intensive project laden with hungry soft synths that used to break up on AG2 set to low in C9, thus far it’s played it fine in C10 - just. The meters are still very high, so it’s not a massive difference, but I’ll take every single .1% of that 12.5% improvement! So from my perspective - fixed, and thanks.

I am running two Windows 10 systems 6950x(10core) and 5960x(8core). I had hyperthreading turned off on both. I turned it back on for both and there was no issue as all. It basically cut the CPU idle % by 40-50%. I havent loaded up a large project to stress test it, but overall I think Cubase 10 feels snappier. So, I am happy with that. :slight_smile:

I did a few quick tests after reversing the registry fix.
I noticed right away that the ASIO Performance meter was acting pretty wild and hitting the red every few seconds with one instance of Avenger and just simple presets.
But there were actually no audible glitches, even if i hit the polyphony very hard.
May i add that i am using extremely low buffer settings of 48 samples wich has worked with the now obsolete workarounds that have been available for High Core count processors.
My theory is that the current ASIO Spikes are just cosmetic in nature and not a true performance issue.

Tonight i will record a session with some more tracks and plugins (no avenger this time)and will keep you updated if it works reliable.

In the past it was always the case when using HT you had to use a higher buffer to take advantage of the threads. Especially with ASIO Guard on i did noticed huge gains on my old 6 Core Gulftown Intel.

As of now i have ASIO GUard off as it gives me a truer representation of performance differences between CPU Modes. Also i must admit that even bigger Projects didn`t stutter even when limiting the core counts on C9.5.
So no need for ASIO Guard yet for me.

Is there any improvement in performance on computers with less cores? I have 10 cores for instance.

Cool :slight_smile:

Sorry for the silly question, but I can’t recall if I have ever applied the “registry fix”.
Where can I find the info regarding the key etc. so I can check if my registry edits need to be reversed?

Thanks.

Thanks for this multicore update. There’s for sure an improvement of multicore usage.

I’ve just updated from 6 core 12 threads i7-3960x CPU to 8 core 16 threads i9-9900k. Tried to open my project made in Cubase 9.5 with 6 core CPU and got worse perfomance with 8 core CPU with some spikes and crackles. After installing Cubase 10, all those problems with same project are gone + my ASIO perfomance meter droped by 1/4. To me it’s huge improvement. Big thanks for it Steinberg!

8-core CPU here (5960x). Didn’t benchmark yet, but feels like no change compared to 9.5 with the properties file. I’ll test properly and report.

By the way, my main concern for CPU isn’t fixed yet. That is, using full CPU when rendering.

By the way, thank you Fabio, for the mood you’re setting here. That is the spirit for a good forum. Finally!

14 cores. Definitely an improvement in performance here. GUI is snappier too.

Disabled all BIOS SpeedStep and all that stuff, except Intel Turbo Max Boost 3. Guess that’s only relevant to certain MOBOs.

I just checked and it looks like the update to build Win10 1809 wiped out the registry key for me. That might explain why Cubase 10 seems smoother/more responsive than 9.5 has recently. I wonder if Microsoft also changed MMCSS behavior in 1809 as it was much worse before? Fabio, any chance you can get into a little more technical detail about what Cubase 10 is doing differently with MMCSS now?

Maybe too off-topic, but it is somehow(?) related in regards to RME audio driver. It has a setting to enable MMCS and I have it enabled. Wondering now if this is still the best way to go together with Cubase 10?

anyone got a link were I can reset all my reg edits I did with Cubase 9.5…im using a i7-5820k 3.30ghz cpu and 32gb ram but not seen any of the processing boost im supposed to get .I deactivated hyperthreading because that’s what I was told to do when I was getting asio spikes in Cubase 9.5 in the last windows update (1803) and I don’t think ive reactivated it.

how can you tell if its on or not and what do you recommend I set my Cubase power settings too ?thanks