Cubase 11.0.30 removed 11.0.20 and won't install 11.0.30


I recently tried to upgrade my Cubase Elements 11 and it’s messed up my installation. My 11.0.20 is gone completely.

This is what it does

  1. It extracts
  2. The welcome screen, so next.
  3. Accept licence and next
  4. Cubase Elements 11 will be installed. required space 634mb
  5. Next, then Install.
  6. After a few seconds process completed with “Cubase Elements - No changes” and there’s finish.

But it’s not installed. I have even tried double clicking on a project to open it and it asks me to go to the Microsoft store and pick an app.

I have tried a PC restart, redownloading, from both the files and the download assistant.

I do have a ticket open but I hoped someone here can help. I’m on a fully updated Windows 10 Home, the rest doesn’t matter as the program isn’t even installed. I tried installing in the default location and elsewhere, I have 50gb free on the drive.


Cubase 11.0.30 is update of Cubase 11.0.x, so it always overwrites any Cubase 11.0.x (same like Windows update doesn’t make a clean installation, but updates your current one).

I would try to download Cubase 11.0.30 from the Steinberg Download Assistant (not, just the update, but the installer) and install it again.

Make sure, you install it to the system C drive, please.