Cubase 11 and Waldorf PPG Wave 3.v - Some sounds/transients can't be loaded (File Permission issue)

I have a problem with the Waldorf PPG Wave 3.v plugin (VST3, latest version). On my system it can’t read some sound sources (transients) which prevents loading patches correctly. The plugin can read banks/patches, but, for some reason, not all sound sources. I’ve tested the plugin successfully in SAVIhost. So it seems it’s a Cubase only problem.

I always install Windows (Win 10 Pro) as administrator and never change anything regarding user profiles, privilegs or file permissions.

For example, the following patch does not loading correctly:
Patch: Ingo Weidener Bank.fxb > Preset: ‘Big Bell’
Error message: NOT FOUND (T330 PC ORCH BELL 2 classic)

I’ve already talked to Waldorf support but they won’t help me any further to fix this. They say it’s a file permission issue. For some reason i’m the only one experiencing this particular issue. I’ve tried changing the owner/groups of the sound source folders (i gave full access to anything) and files numerous times without any luck.

Has anyone a similiar problem or an idea how to fix this? For more technical details please see me third post in this thread.

Thanks in advance!

better desctiption below

Here comes a detailed description: of the problem

Problem:
When loading presets in the PPG plugin in Cubase, some presets don’t get loaded correctly. It looks like sound sources (think of WAV files) needed in those presets don’t get loaded. They are probably blocked from loading due to insufficient permissions.

Setup:
OS: Windows 10 Pro

VST host (DAW): Steinberg Cubase 11 Pro
(owner is ‘SYSTEM’)
‪C:\Program Files\Steinberg\Cubase 11\Cubase11.exe

VST plugin: Waldorf PPG 3.V
(owner is ‘Administrators’)
C:\Program Files\Common Files\VST3\Waldorf\PPG Wave 3.V\PPG_Wave_V3.vst3

Presets and sound sources folder of the VST plugin:
(owner is ‘Administrators’)
C:\ProgramData\Waldorf\PPG Wave 3.V

The app and plugin is loaded in this order:
OS > VST host > VST plugin > Preset (which loads needed sound sources (like WAV files))

Further details:
The owner of Cubase11.exe (the VST host) is ‘SYSTEM’. I’m always logged in as administrator in Windows. The folder (C:\ProgramData\Waldorf\PPG Wave 3.V) containing the problematic sound sources grants full access to ‘SYSTEM’, ‘Administrators’ and ‘Owner’. When i add ‘USER’ to that folder and give it full control, a formerly shown error message ‘(SOUND SOURCE) NOT FOUND’ isn’t displayed any longer when loading a preset in the VST plugin. But still no sound can be heard. So it looks like adding ‘USER’ seems to have an effect but doesn’t solve the entire problem.

I can run the same plugin w/o any problems in SAVIhost whose owner is ‘admin’ (‘admin’ is the name of my Windows user account).

Running Cubase11.exe using ‘run as administrator’ doesn’t solve the problem.

Is this an app ownership issue?
Why is Cubase’ owner ‘SYSTEM’ when i’m always logged in as ‘admin’ (my local Windows account with administrator privilegs) and install all software via that account? Shouldn’t the owner of Cubase not be ‘admin’ ? To me it looks like that’s maybe the problem since SAVIhost is working, whose owner is ‘admin’.

The problem boils down to the .WTB files.
These files contain the transients which can’t be loaded by the PPG plugin. The strange thing is that these files are located in the same Waldorf/PPG content directory under ‘C:\ProgramData\Waldorf\PPG Wave 3.V’. They have the same file permissions set as presets and WAV files in that folder structure, which can be loaded without any problems by the plugin. So only the .WTB files cause problems for some unkown reason.

Installing PPG as adminsitrator doesn’t solve the probem either.

Hello A4000
I just checked, but I don’t have this patch?

Patch: Ingo Weidener Bank.fxb > Preset: ‘Big Bell’

Where would he have been with you?

gruß Chris

Hi Chris,

That preset is in ‘Local Library > PPG 3 Sounds by Designers > Ingo Weidener Soundset’. You can also try to load files from the Waveterm library. If i try load them here i can’t hear any sound. They are the problem.

Hello a4000,
I don’t have this patch in the system
Did I forget to install something??
See image


The WTB files below all work,
gruß chris

Strange. Maybe install the latest version if you don’t have it already? Could you look at the owners/permission to compare it to my system? There must be some issue with permissions on my end. If you can load the WTB files then you’re fine, i think.

So, all of my patches can be found at the following link:

C:\Program Files\Common Files\VST3\PPG Wave 3.V Sounds
The installation program installed it there.
I don’t have any other patches. The computer was reinstalled in January but is running Win 11

In the old backup under Win 10, the folder for the sound patches is the same
There was yours
Patch: Ingo Weidener Bank.fxb > Default: ‘Big Bell’
not to be found either!

Maybe you should uninstall everything that has to do with PPG again and reinstall it

greetings Chris

Thanks for checking your configuration. Interesting that your content folder is under ‘Programm Files’ not ‘Program Data’. I wonder if it has to do with the Windows version (10 vs 11). I reinstalled the plugin cleanly several times but no luck so far.

This folder is empty for me under Win 10 and Win 11

C:\ProgramData\Waldorf\PPG Wave 3.V ]

As a test, copy this content into the one I described and then load the patches into the PPG?

Of course, always make backups beforehand :-))

I might try that. It would be very surprising if the plugin could still find the presets after moving the content folder. I’ll also try to find the path variable in the registry. Then i could changed it accordingly.

you don’t have to change anything in the reg

Simply search for the new folder in the program under load file and load the fxb bank

somehow this topic belongs in the Vst category

The preset themselves might work fine but what about transients and WAV files used by the presets? The question is where the preset or plugin is looking for them, respectively where the pathes for the sound sources used in presets are defined.

tell me which path your sound files are in exactly

I’ll copy mine there
Let’s see what happens

[OK, you’re right
the banks continue to function
but you can’t select the samples

Thanks for trying. My pathes are all in my third post.