Cubase 11 doesn't load the Steinberg Hub. Is this caused by a server problem?

The Steinberg Hub doesn’t load for you either? I mean, the news, etc. This has happened before but updating the program solved it. I installed the last update a few hours ago on (Download Assistant) but now that didn’t solve the problem. My internet connection is good: the ‘Hub’ and ‘Help’ menu links can be opened easily within Cubase. I put Cubase to the firewall exceptions but no change. Note: it wasn’t among the exceptions so far and the Hub was good.

Do you think this is a server problem?

The Hub looks like this now :


Are you on Mac or Windows, please?

Most probably this is caused by antivirus or firewall settings.

Hi, sorry: Win 10.

That’s not good because if it’s really an antivirus or firewall settings then the “awesome” Windows update must have corrupted something because I haven’t changed anything.
Then I think you have a working hub .

Edit: I temporarily turned off the firewall and antivirus component also and the Cubase still didn’t load the Hub. So I don’t know …

I have this problem too. It started yesterday at some point I am on win 10 and cubase pro 11. It’s not a firewall problem since I have not made any changes to the default windows firewall and like the original poster I did try turning it off anyway just in case.


OK, I can also reproduce it. It seems to be generic issue then. Sorry.

Reported to Steinberg.

1 Like

Seems to be ok now! Guessing someone somewhere turned something off and on again :slight_smile:


Yes, it has been fixed. :wink:

Yes, it works now, thanks!

Last night I was already looking for what I (or windows update) installed that hacked this feature. :joy: