Cubase 11 HiDPI issue (150% DPI)

Buying expensive new hardware, just because the software doesn’t do a proper job?
And what kind of monitor would that be? Certainly no 27’’ HiRes monitor. But who in the world would want to downgrade from the excellent screen of HiRes monitors, enjoying them all the time for everything you do on the computer, for the sake of a halfbaked Cubase HiDPI??? Or who in the world would want a giant screen, where you have to turn your neck all the time, all the more wearing glasses?

The ONLY acceptable way is well working HiRes software.

+1
similar issue here with 125% scaling
https://www.steinberg.net/forums/viewtopic.php?f=307&t=202158

I can not understand it, how they do their testing (alfa, beta). I offered them my testing services so many times. This is so obvious problem. How is possible, they go out with such an issue - and calling it better scaling. I cannot get it. I paid so much money (even I have nuendo 10.3 already) to finaly work on proper HiDPI system, so I bought Cubase11 for a big money and it is even worse, than before :frowning:(((((( I am so sad. And Steinberg’s support just sucks. I think we can await a fix in ther version 12 … if ever… meeh :frowning:((

It was a joke :wink:

I have a 3K widescreen monitor (3440x1440 ). It works brilliantly with Cubase.

https://youtu.be/VWzKWgL0hJ8

Found my first problem with HiDPi, (Widows scale 125%). When you drag a sample from the MediaBay into the Sampler Control window, the project window “jumps” into a separate window. With Windows 100%, it’s okay.
There are two options: either my system or a broken HiDPi.

Windows 10 20H2

When It didn’t work I left it on 125% (=100% in Cubase) as 150% was too much.
rn, 125% looks absolutely perfect. I won’t even bother 150%

One thing to test is in the Compatibility setting (right click)>Change HiDpi settings,
Try overriding the application or OS (either or) and see if that helps or hurts.

Can someone test a Bug I have had with HiDPI from day 1 which is one of the reasons I never use it

use any highdpi mode, then load a sample into your sequencer, then select anywhere in the sample and use the ALT modifier to cut the sample at the mouse pointer… for me in HiDPI mode this works about 20% of the time, and the other 80% it makes a copy of the sample (as if you were alt + dragging the sample)

would be cool if someone could test also to see if it’s just a problem with my setup or not, as i’m sure someone else would have noticed by now if not

doesn´t work

Exactly!

this topic
https://www.steinberg.net/forums/viewtopic.php?f=307&t=202460

Missed the joking completely. I mean, we are talking about dead serious display issues :slight_smile:

EDIT: fixed the url now
https://www.steinberg.net/forums/viewtopic.php?f=310&t=202288

HiDPi, to the furnace! At the Windows 125% scale, UAD plugins do not run either the interface or the plugins themselves! At the same time, on different plugins of the GUI, “broken” in different ways. Even the operating plug-in, when you switch to “Allow Window to be Resized” mode, turns off {the plug-in does not hang, but bluntly turns off}. Next, only rebooting the plug-in solves the problem. With a Windows scale of 100%, everything is fine. Do I have a mind, how can a picture affect the operation of algorithms?
Maybe I’m the only one?
NVidia 1050Ti, drivers are fresh.


It happens to me similarly with vertical lines

Cubase GUI should not be this big of a headache for this many users. My experience has gotten better w/the addition of (Finally) being able to use 125% but this shows how much they’ve kicked the can down the road.
Users have been dealing with windowed glitches and gui issues for sometime now.
It’s 2021 and other DAW’s don’t seem to have gui type of issues (that I 've come across) like Cubase does.

They seem to be addressing some things but the pace of fixing things you are pretty much forced to learn workarounds which is not what you want to hear when it’s considered a Pro DAW

100% agree

and about one feature I didn’t know that exists - in my video I am upset not to have smaller increments in zooming desired tracks. MY FAULT and I am deeply sorry for blaming Steinberg in that particular thing. There is an option above the zoom slider (small triangle) to turn off the SNAP TRACK HEIGHTS. So one more sorry Steinberg. But I think, that should be switched off by default IMHO.

Hi,


I’m sorry to hear you encounter issues with the HiDPi mode. Regarding the ever-shrinking plugin, have you tried turning off the DPI-Awareness of the plugin window?

Here’s one way to do it: https://helpcenter.steinberg.de/hc/en-us/articles/360017509919-Cubase-11-Using-DPI-unaware-plug-ins

Lemme know the outcome and if it still doesn’t work I’ll investigate too.


Cheers,
Armand

Hi Arman, thank you, that someone finally listen to users … that is a gr8 message.

Problems with evershrinking plugins are here from the Cubase version 9.5 till these days (even in Nuendo 10.3). I Bought every single (expensive) update and even crossgrade to Nuendo in hope, that this will be solved in higher version. I don’t need any new function - just fully working UI. So much money spent for nothing. And three or four years in pain with this. I even bought a trully hyper-expensive downgrade now (yes, for me it is a downgrade from Nuendo) to Cubase 11. Because of promised full support of 150% DPI in windows etc. I thought, this issue came from the problem with not matched DPI from windows. Which I hoped will disappear after buying new version of Cubase 11 - You promised, there will be these thing sorted - Nope, … it is still there and it is even worse :frowning:(((((((((

Plugins which are causing this are mostly plugins which are already resizable (based mostly on an OpenGL platform in my opinion) IK multimedia syntronik, Melda and many others
But there are some plugins even without OpenGL resizable platform causing this (Like McDSP)

The whole Cubase desktop is kinda blurry, with ghost and with doubled lines, and distortions. And NOT it is not problem of my Screen, or Graphic Card, because I have (as you know) Nuendo 10.3 here, which is working perfectly fine in that way (no blur, ghosting, distorted lines - only this shrinking issue)

I would welcome DPI settings in Cubase/Nuendo, which I can set just for the mixer, or the project window (like I’d like to have 175% DPI project window and 150% mixer etc) … I suggested this even the DPI ZOOM a years ago. Nobody listens.


And no, setting these plugins to “allow to be resized” does not help it. And for most of these plugins with that issue is not that option enabled

only exception is trully the McDPS (I think is not OpenGL)… which caused evershinking problem, but after enabling that option, the problem dissapeared completely

I am really glad, you’ve added the new “Resize” function for old (non scalable) plugins. But I’ve suggested this too before 3,5 year ago, even offered technical support to this for free.

Another issues with older plugins, which have that “allow to be resized” option now.

many times the knobs are not matching the doublesized (Allow windows to be resized) windows of a plugin, even it is displayed correctly as a picture

  • like all NI instruments with not resizable UI, knobs are not matching mouse pointer… and after changing some slider, knob, there is a glitch of that plugin, so the UI falls apart

In the mixer there is a very dark color grid (almost invisible) in the background of the plugin slots (only).

That happens only, when I set lets say 175% DPI for that particular screen. After setting it to recommended 150% DPI, the problem disappers completely - but the plugin columns are not spreaded evenly … can make you a video too

And many other issues. PLEASE ARMAN, write me a personal message to my Facebook.com/fink.petr (add me to friends), or write to my mail: petr (at) fink.cz
I’d like to cooperate, making you all videos with issues, and testing the solutions on my PC configuration to help solve all these issues finally.

Even my english is bad, believe me, I am a clever and reliable guy. Please contant me personally.

Thanks a million, Petr

Hi Petr,

Thanks for your invaluable feedback!

I highly recommend you try the “Allow to be Resized” feature for your main plugins that do not support HiDPI and that you report strange behaviors to each of the manufacturers. We are already in touch with the main VST manufacturers, but they have not all been able to release a new version yet. This is for most of them a quite strong and hard transition. Let’s be transparent here. It’s also for us a long-term planned transition where we need to find the correct balance between DPI-Awareness and stability for each version. In this respect, I have reported several bugs that are not acceptable in terms of usability, for instance the floating transport panel without icons that you pointed out. Please send me a pm with similar bugs where the GUI is unacceptably broken (buttons not present, not working). For each case I need a clean screenshot and eventually steps to reproduce if the bug is not so obvious to reproduce.

Back to the “Allow to be Resized” option. Unfortunately, some plugins might react weirdly at first. You might encounter audio glitches or buggy GUI. I recommend you turn off your speakers when doing so and to at least try to reopen the window once you enabled/disabled the option. If a plugin still misbehaves in both modes, then I suggest you contact the technical support of the plugin manufacturer first. This is a process you should only do once and for all and hopefully after this you’ve been able to figure out which plugins behave better in this mode than others, and which plugins should be worth nagging the technical support of the corresponding manufacturer.

I will discuss the option for a custom scaling factor with the team. This option would nonetheless affect the entire application. Regarding this option being to be customizable pro context/window, that is something that might be addressed in a future major upgrade.

Cheers,