Cubase 11 moving my midi recording about a sixteenth note earlier

Title says it all - I record midi and then when I go to edit it, the midi notes are all about a 16th note early. I’ve checked the “track delay” in the inspector and its set to Zero - what’s weird is that this occurs on all my midi tracks. Is there some universal “move my midi a 16/32 note early” preference that I don’t know of?

Any help would be greatly appreciated.

Thanks
F

You might want to check out the compensated delay constrain button on the top left. Also make sure the track is in musical mode. Yellow button located in the track selection on the main page. One other thing make sure your AQ (auto quantize) bottom left button is off. If nothing else works try clearing your preferences. Cheers

I’m having a similar issue… Seems like when recording, even though I’m playing on time, all notes are too early. Note sure why it happens… if there were a bit too later I would say it’s a latency issue but it’s not.
I tried the suggested solution but no help.