Cubase 11 not opening after safe mode screen

Having trouble getting Cubase 11 to work at all for me - I had 10.5 but upgraded to 11. I kept having Cubase crash on me the second I tried using any third party sample, so I’ve now gone through everything I can think of:

  • uninstalled 10.5 and 11
  • uninstalled and reinstalled Download manager, Library Manager, and eLicenser Control
  • reinstalled 11
  • made sure my Windows is the most current version
    Now when I open Cubase, it will try to open in safe mode. I’ve used every option available, even just hitting “cancel” and not trying to get it to run in safe mode at all. It will close the safe mode window, act as if it’s going to load up, and then the loading screen disappears and nothing happens. I’ve tried running as an administrator as well with no luck. Any possible way to get this program to work for me?


Try to disable preferences from the Cubase Safe Start Mode dialog, please.

I just tried this per your recommendation; the splash screen came up, but when it leaves, the program doesn’t launch after that. I did try this before as well, along with the other options it gives me in the safe mode screen. This was the same response it gave me before.



Could you try to delete/rename (both) Cubase preferences folder, please?

Cubase Preferences folders are:
Mac: ~/Library/Preferences/Cubase X
Win: %appData% Steinberg/Cubase X_64

Could you attach a .crash/.dmp file mentioned in the Safe Start Mode dialog, please?