Cubase 11 Pro cannot use 5.1 audio using Logitech Z906

I am currently using the latest version of Cubase 11 Pro on a Dell XPS8700 machine. I am attempting to add a Logitech Z906 5.1 system to my set up. As a “plug and play” system using the machine’s sound card, it’s fine. It’s using a six channel mini jack loom from the up to date Realtek driver to the Logitech’s powered sub-woofer.

My problems with this set up arose when I tried to patch the outputs of a Cubase 5.1 surround project to the sound card. The sound card does appear as an option, as a generic driver, but it only shows two mono outputs as a stereo pair (Realtek Driver L, Realtek Driver R). This patch option cannot be duplicated over different outputs in the 5.1 channels. In short, a project needs 6 channels of output but Cubase is only recognising two.

It looks as if there is no easy way to let Cubase access the individual outputs in the sound card, unless it is an independent ASIO audio interface, like a Steinberg U824 or Focusrite Scarlett 18i20, with compatibility as well as individual signal outputs.

Is there advice from anyone who may have a similar setup and who has experienced a similar set of problems but with a solution?

TIA
Scott

Have you tried using Asio4All ?

The driver wouldn’t load initially so I copied the .dll file across in to the Cubase 11 directory. That got me past the initial error message and Cubase can now ‘see’ the driver.
Using the “multipanner” in Cubase I’m now able to see and isolate the 6 audio channels except for one - the sub-woofer (Channel 4). It is completely lifeless - although I can hear things coming through the sub-woofer speaker. It sounds like other channels “bleeding” through.
So I’m 90% there but would still appreciate any help in getting me across the line.
Cheers!
Scott

Okay, I’ll try to help you out with this one. I’ve got my system at home set up for 5.1 output but it’s a little bit of setup that needs to be done to get it working.

First I’m not aware of any Audio interface (By this I mean a dedicated external box that hooks up via either usb or thunderbolt like a Universal audio Apollo twin solo or duo or a focusrite scarlet or steinberg ur22mkII or similar) that actually supports 5.1 inteface output out of the box. They’re all set up for monitor speakers which are just stereo. So if you can find an actual “audio interface” box that does support 5.1, let me know.
So we need to look at audio cards that actually have ASIO. don’t even try to screw around with asio4all in my opinion, get something that has ASIO support So I’m going to recommend what I have Creative Sound Blaster AE-7. It’s a PCIe card so you have to have a free card slot and have a PC. So there’s that.It’ll do 127 dB DNR hi-res 32-bit / 384 kHz playback via ESS SABRE-class 9018 DAC and DSD64 playback support and it comes with a fully certified ASIO driver.

Next, once you have your card installed, you need to hook up with the 3 audio cables (not the optical cable… the optical cable just doesn’t work well for me, but your mileage may vary) and make sure you calibrate your 5.1 surround sound with your speakers.

Once you’ve got that done, time to configure your cubase. by default it will start up in stereo mode. So you need to set up a 5.1 stereo configuration and map the outputs accordingly. How do you do this. Pretty simple. Launch cubase 11 , create an empty project,select a folder to put it into. Then in Cubase select “Studio”>“Adio connections”> click “outputs” tab and click “add bus” and from configurations click the dropdown and choose 5.1. then map the outputs for the device ports. You will need to disable the stereo bus to map all the outputs correctly.

The thing that you’ll also need to do is make sure you set up your instruments to make use of the 5.1 outputs. for example if you use Kontakt or Komplete Kontrol you need to set it up so that Kontakt will output to 5.1. To do that you go into Kontakt, load up your instrument (s) and right click below the primary output channel (which by default is 2 channels L/R and titled st1) you should get a new window that pops up saying channel name and audiochannels, click and scroll it up to 6 channels. 5 speakers and 1 subwoofer and then map the channels.
Then you need to go into the advanced setup menu for the instrument and go into instrument buses and add the surround panner. (if you need more details on this I can help but this is running afield of how to set up 5.1 in Cubase.) The point is, there are several steps here… The first is setting up the audio connection is first, then you map the outputs to the speakers, then you set up the virtual instuments to output to 5.1. Then you can add the instrument tracks to cubase and you should be good to go. The thing to remember though is that you need a fairly beefy audio card or audio interface that can do the processing needed to handle 3 times the number of audio outputs.

So SB AE5 or AE7 should be fine. Don’t waste time with the AE9 imo though

Thanks very much for taking the time to provide a comprehensive reply.

I appreciate your views on ASIO4All but, for me at least, it has provided a way forward and at no cost.
TBH, I’m reluctant to fork out on another sound card when I’ve got so far with my current set up.
I’ve used Cubase since v6 so I’m fairly au fait with getting it going, but thanks for your offer of help. Apart from the absence of my sub-woofer channel in 5.1, it’s all OK.
Cheers!
Scott

Glad to help. You should have 6 channels to define lfront rf , lrear right rear, then centerchannel and LFe (low frequency emitter aka subwoofer) that one is tricky, I suggest using something like apocalypse or damage to find which is which. Once youve got it all set you should be able to use your mixing board to pan across your speakers appropriately.

We’ve got all channels identified and working.
On the Cubase multipanner I can see all 6 channels as individual volume indicators - all except Channel 4, the sub-woofer.
The subwoofer unit itself is playing a combination of channels. We can’t figure out what’s wrong. :slightly_frowning_face:

Hmmm, that’s odd. I’d honestly look at asio4all as the source of the issue. Particularly if you’re getting discrete output from each channel. (best test there is to make certain that you are able to turn off output to each speaker individually and that you don’t actually get output to the other speakers just to be sure)
If you have a true 5.1 sound card, try a free version of kontakt from native instruments and set up an instrument to be 5.1 and verify that you can output to individual channels and mute the others and you only get output to the correct channels. This is what I mean by using something like Damage or Soundiron’s apocalypse Both are percussion instruments with extemely low registers. This is a good way to verify that your soundcard’s asio driver is working correctly for you. If you drive a signal to the LFe channel (oh that reminds me, make sure you don’t have bass management turned on for your card… because if you do, it could be by passing your LFe channel completely. Some bass management systems (believe it or not) will play part or all of the bass signal to your normal speakers… I have seen one actually omit the LFe output completely.

Also if you try it in kontakt and it works there but not in cubase, that would indicate some conflict there as well. And since Kontakt can use non asio mode you can try that too. Anyway, I hope this helped some. Again, not shilling for creative, but they’ve been the most help with sorting it out for me.
Good luck .

Steve

Yup! As a standalone system, the 5.1 channels all work discreetly and as they should. It’s only in Cubase that the missing channel happens - so it’s very likely an ASIO issue. My soundcard is a Realtek and any bass management functions are disabled.
Having tried all of your suggestions and all of mine, it would appear that an ASIO supported soundcard might have to be the next step but, as I’ve mentioned, I’m not really up for spending £200 on a new Creative one. I might just have to put up with it - unless anyone from Steinberg has any further suggestions and/or advice.
Happy New Year!
Scott