Cubase 11 Pro MIDI does not follow tempo (Musical Mode is ON)

Windows 10
Cubase Pro 11.0.41 Build 448

Before asking this question I have searched the forum and there were a few questions like this one but they were for older versions of Cubase.

My MIDI parts do not follow any tempo changes I make and go out of sync.
In the Track Inspector I have every track set to Musical mode. In fact Cubase defaults to that setting but to be sure I have checked.

This is what is happening.
My project tempo is 126 Bpm.

I am copying a base line of a track that is 137 so I import the audio file, set the tempo to 137, making sure using the metronome that each beat of the track I am copying is falling exactly on the beat.

Then I play in base line (Ample Sound P Bass) by ear, then in Editor I go through note by note making sure each note I played falls exactly where it does in the audio.

Then I remove the audio track and return the the project tempo back to 126 Bpm.
However when I play it back the MIDI is all over the place
In previous versions of Cubase the Midi is automaticly aligned to what ever tempo I set.

Where Am I going wrong?

Do you mean Musical Time Base (the yellow quarter note)?

I think maybe the answer to your question (why is MIDI all over the place) may be related to the details of how you did that.

Can you describe in more detail what you did there?

Hi alexis

Thank you for replying.

If you open the Track Inspector and then click on each track in the Track list, in the Track Inspector below the Mute, Solo, Read & Write buttons is the Yellow Musical Note (toggle time base), Lock, Show Lanes & freeze buttons. I have the yellow button clicked each track is set to Musical.

How I did things were exactly how I described.
I imported the audio file (its a 137 BPM TRack), set the Project tempo to 137, auditioned it by ear to make each beat of the songs matches exactly using the metronome (it is bang on).
Then, using my Keyboard with Ample Sound P Bass loaded, I played in the bass line by ear.
Then in Cubase’s Midi Editor I go through note by note making sure each note I played falls exactly where it does in the audio track so both are synced exactly.

I remove the audio track who’s base line I have just played in and return the the project tempo back to 126 Bpm.

The MIDI should slow down or speed up accdoringly to the project tempo or Tempo track is using that, or at least it used to.

Often times I would play things in at a much slower tempo (easier) then just set the project to what ever tempo my project is in.

Screenshots please? Is the musical time base used?
Together with musical mode, the notes should stay on their musical position.
If they stay on their time code position with tempo changes, linear mode is selected.

The Mode is really irrelevant since it only applies to Audio & not MIDI.

But the behavior sure sounds like the Track is set to Linear Timebase and not Musical Timebase. However @KennyEastMids description has Musical Timebase enabled. It would be real useful to see screenshots of the Project Window at both Tempos & maybe some closeups of the Track’s Inspector.

I’m not sure why there is a time base switch on the MIDI or instrument channels as well.
If the behavior wouldn’t matter, there would be no switch, I guess.

The switch, on the track, determines what’s happening on either mode if the tempo changes.

It doesn’t matter for stretching the length of the MIDI. MIDI Parts always behave just like Audio Events in Musical Mode - which controls stretching.

But the Timebase determines if the start of the MIDI Part is anchored to a Bars & Beats Timeline (Musical Timebase) or a Minutes & Seconds Timeline (Linear Timebase).

The track icons (yellow quarter note, black and white clock) aren’t modes, they are Time Bases labels.

There’s only one mode, “Musical Mode”, like that little check box in the Pool. It only applies to audio, letting it stretch when the tempo changes. Musical Mode doesn’t apply to MIDI.

MIDI always stretches when the tempo changes, so it always acts as if it were in musical mode in that respect. That behavior can’t be changed, or switched to another “mode”.

The icons on the tracks, (yellow quarter note, black and white clock - for Musical Time Base and Linear Time Base, respectively), are selections for whatever events are on the track, Audio or MIDI.

When the tempo is changed, The selected Time Base determines *where the beginning of the event is placed, not how the event stretches.

So like Raino said, if you change the tempo:

  1. With the track in Linear Time Base, the beginning of each event will stay at the same clock time (minutes/seconds into the project) after changing the tempo as it was before.
  2. Conversely, With the track in Musical Time Base, the beginning of each event will stay at the same bar and beat after changing the tempo as it was before.