Cubase 11 pro - UR22C TAB doesn't show in Inspector

Hi folks,

since I’ve upgraded to Cubase 11 from version 10.5, I don’t see the UR22C DSPMixFx Inspector tab anymore.

I’ve already checked if the Control Room is enabled and it’s not.

(also I tried by enabling the Control Room and disabling it again, but nothing changes)

Any hint?

Thanks and regards

You have to have something connected in Outputs in Audio Connections. Not really intuitive, could not find it in the UR-C manuals, but true.

Thanks Steve for your help. Do you means I should or shouldn’t have something connected as outputs in audio connections? I currently have UR22C connected both as input and output.

I was saying you should, and you do.

Also the inputs and outputs have to be routed on the selected audio track.

Also, in Audio Connections, try setting the input and output to the first ones available in the list… that help?

Thanks Steve, but I tried everything you suggested without success… mmm
Any other idea? :slight_smile:

Is the audio track routed to stereo out?

It probably won’t work if it’s routed to a group.