Cubase 11 Upgrade and Installation - Download Assistant Issue

So I’ve got key for update from 10.0 to 10.5, updated my USB eLicenser, got grace period upgrade, now I have Cubase 11 Pro license on my licenser.
But there is an issue with Download assistant (DA).
So I’ve got an update for DA, now it’s showing me big red button that offers me to login on Steinberg site. Click. I’ve succesfully entered my account in Steinberg site. Now it says “To authorize Steinberg Download Assistant, you must allow your browser to open Steinberg Download Assistant.”, okay, Steinberg Download Assistant is opening from browser and it shows big red login button again and nothing else. “Remember me” checkbox doesn’t change whole situation. So looks like authorization didn’t go well.
Tried with last Firefox and MS Edge, same stuff.
So if there is no direct download links for Cubase 11 on site, how do I fix DA or where can I find Cubase 11 download link?

Thank you.

Same problem.
When i open Steinberg Download Assistant, it open chrome / firefox / edge, want to approve to open software…
And… Nothing happen… It still have “Identification” popup.
Reboot, re install, not working.

Yep - this has been going on for several days now - though it doesn’t seem to be affecting everyone as some people are able to download and install stuff without issues.

There is a thread about it in the Cubase 10.5 section, but despite raising a ticket there has been no response or work-around that I know of.

Same here. Tried Firefox, Chrome and Edge. All was well before this.

I’m also having the same issue, with the DA, pls fix this issue

I found the solution on the 10.5 Forum.
You just have to resynchronise your windows Clock.
My Windows 10 clock was 2 minutes late, i have updated and launch download assistance > all is fine !
If time.windows.com wont worky, simply ajust manually your clock with official time like this : https://time.is/fr/Belgium

same problem here! can`t download anything!

Thank you, it worked for me… :astonished: :astonished: :astonished: :stuck_out_tongue:

Amazing but syncing my Windows clock fixed Download Assistant. Now I just have to wait and see if the actual upgrade download works… :astonished: