Cubase 11 ( Win) & SSL Nucleus (ipMIDI) = MIDI Port Errors

Cubase 11 (Windows 10) alongside ipMIDI (communication driver for SSL Nucleus, among other products) causes MIDI port errors on playback/any other MCU activity.

Been down the rabbit hole with SSL tech support already, and have determined that something had changed in the MIDI port handling because Cubase v10.5 DOES NOT have the issue. Also to note, my other DAWs on this same system (S1, REAPER, Live) all work with the ipMIDI ports for Nucleus perfectly.

Cubase 11 has been set up properly with two MCUs (1 and 2 since Nucleus two banks of 8 faders) with bank one going to “Ethernet MIDI port 2” and the second going to “Ethernet Port 1” (that’s the way the order has to be). Mackie Control set to “Cubase” or “Compatibility” has no effect - tried both. Cubase ket commands set to defaults and all of the ipMIDI ports (1-6) have loopback disabled - all according to the Nucleus setup guide to work properly with Cubase.

All ready to go…I press play and ipMIDI ports 2, then 1, then both error out as a Windows popup. In the ipMIDI CP, both port 1 and 2 gets muted (not good) and no more communication with the Nucleus takes place. I unmute them, try again, same errors.

Steps to reproduce the issue:

  • Have Nucleus properly installed and operating in Windows 10
  • Setup Nucleus in Cubase 11 via installation and user guide
  • Open a new or existing project
  • Press play or any transport button. and/or move a fader
  • Monitor lower right Windows event popup area for ipMIDI port errors

Through thorough testing, I stumbled upon a way to get it working, but it’s only temporary for that open session/song. Once I save/close the project and even open the same one again, the errors return on play:

The way to clear the errors (after unmuting the ipMIDI ports in its CP) is to go to Cubase’s MIDI Port setup and check (or uncheck) the option at the bottom called “Use Device DirectMusic”, hit OK, then play - perfect and smooth sailing from then on - until close. It doesn’t matter if DirectMusic is on or off when entering the dialog, as long as I switch it to the ‘other’ way, I get smooth MCU use with the Nucleus from then on.

Anyone else having this issue on Windows with ipMIDI and Cubase 11?

Again, v10.5 does not trigger the errors, and my other DAWs work as expected with the ipMIDI setup.

Thanks for reading!

Hi,

Sorry I have no Nucleus, so I can’t test it. But from the description, it sounds like a MIDI loopback issue. Are the Nucleus MIDI Ports disabled from the ‘All MIDI Inputs’ in the Studio > Studio Setup > MIDI Ports Setup, please?

Hello Martin,

Thanks for replying back!

All of the ipMIDI port entries (labeled “0X. Ethernet MIDI”, where ‘X’ is the port number. SSL recommends setting up 6 MIDI ports as the Nucleus can control up to 3 DAWs at once at two MCU 8-fader banks at once) are checked “Visible” / State is “Active” and “In 'All MIDI Inputs” are all DISABLED / unchecked.

As a side note, within the ipMIDI control panel, the “Loop back” option is also disabled/unchecked per SSL’s installation instructions.

Exact same setup of everything in Cubase v10.5.30 doesn’t have any of these issues.

Hi,

As far as I know, there is no change in Cubase 11 in this area.

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Hello,

I just did as you exactly suggested and opened Cubase 11 in Safe Mode, chose the disable prefs option, choose my audio interface, went into MIDI devices and unchecked the “All Inputs” boxes for all of the ipMIDI Ethernet ports, added two Mackie Control option and set them to the correct ports.

Same MIDI error messages - no change at all.

Just for good measure since I have a rather fresh install of v10.5 on my system because of this issue, I did the same Safe Mode start in v10.5, did the same exact few setup items just like I performed in v11…and…it works perfectly fine. No errors or anything.

I’m using the latest production version of Cubase 11 (11.0.20) Pro on Windows 10 x64. Latest ipMIDI v1.9.1 as well

So: Cubase v10.5. Studio One, REAPER, Ableton Live = works as it should w/ ipMIDI & SSL Nucleus
Cuabse v11 - not so much (even with minimal and exact same prefs as v10.5)

Hi,

Sorry, I’m not Windows user, so I don’t know, how exactly is MIDIO-X working. Can you attach it to any MIDI Port without sending the data to this specific port? Can you just observe the MIDI Port, please?

If yes, could you try to do so and observe the ipMIDI ports? Is there anything different, if you use Cubase 10.5 and Cubase 11? I still expect some kind of loopback.

Hi Martin,

I really appreciate your time and advice given to examine the issue.

Come to find out, it IS an issue with the current production build of Cubase 11 and nothing else.

The next production build should clear this up.

Thanks again!

Keith

Hi,

Could you be more specific, please? Do you know what happens under the hood? Can you somehow reproduce it without SSL Nucleus?

I would be glad for tis, but first, we have to identify the problem. Could you help, please?

Hello Martin,

Sorry, but I have no specifics as to what’s going on under the hood in respect to the issue. It’s not really Cubase-to-Nucleus, more in reality Cubase-to-ipMIDI . Cubase communicates MCU to the Nucleus (and other SSL products that have MCU control) via the outsourced ipMIDI product.

Keith

Hi,

Sorry, I don’t know ipMidi. I have just downloaded it for the very 1st time. But as far as I can see, it has something in common with the LoopBe. As far as I know, the LoopBe is known for the “trick”, it connects the MIDI Input and the MIDI Output of the same name, so it creates the MIDI loopback.

Does ipMIDI do the same?

To use LoopBe properly, most of the time, you have to use MIDI Ports with different names. So for 2 MIDI In/Out ports, you need 4 different MIDI Ports with different names. Otherwise the MIDI loopback is created by the LoopBe. Isn’t this the case?

Hi Martin,

ipMIDI specifically has a debatable “Loopback” checkbox, which affects all active MIDI ins and outs happening, and via the Nucleus’ setup guide, strictly advises to have that box unchecked/disabled for all to work properly.

In long back and forths with SSL customer support, I definitely have done everything multiple times right to the letter of their setup guide.

This is a Cubase <> ipMIDI communication issue, that as I said, will be fixed shortly.

Keith

Hi,

I have tried to use ipMIDI, but it doesn’t work for me here at all.

Could you please use MIDI Monitor application and monitor the ipMIDI outputs and input? What data do you get, please?

I’m on Windows 10, not Mac, as MIDI Monitor is a Mac app only.

Did you read my offline PM I sent to you?

Hi,

Oh, sorry, I was thinking ipMIDI is for Mac only and LoopBe is an equivalent for Windows. Now I understand, it.

Thank you, I got it. Still puzzled with it. :thinking:

Did you contact Steinberg Tech Support?

Yes, I have.

I have this exact issue with the same hardware and software setup and settings as Cinemascore. It’s driving me insane and am unable to fix it. Have also tried same troubleshooting procedures. Two things I do know;

  1. Possibly has something to do with the Windows update (KB5003173) as these issues began around the time of this auto-update. Tried rolling it back but could only remove some patches (thanks MS)
  2. During investigations I have noticed that the issue stops when you disable the ipMIDI output for each of the Mackie Controls associated with the Nucleus. That’s interesting but unhelpful as doing this means the Nucleus can’t ‘talk’ to Cubase. It does point to something going on here though.

Might have to roll back to Cubase 10.5 or else get nothing done.