Cubase 12.0.10 Crashing frequently performing multiple tasks

After and extensive trawl through the forum it is apparent that there are a multitude of fellow users experiencing a number of the same and or similar issues as myself.

Cubase 12.0.10 MacMini9 (M1 2020) 16GB Monterey 12.2.1, PCI Card Universal Audio Solo, (NO CRACKED SOFTWARE) all plugins & effects genuine 64bit plugins.

Cubase crashing performing the following tasks


the above issues are what I have encountered thus far, i was hoping the 12.0.10 update would iron out a few of these issues but if anything things have only become worse, achieving any kind of workflow has become impossible rendering C12 unusable, I expect I will be no better off after this but if anyone can please offer an kind of insight it would be greatly appreciated, cheers

Cubase (19.2 KB)

Thanks for the report. We will have a look. I assume you are running Cubase in native mode, right?

yeah running in native mode

I can confirm the performance issue with the group tracks, using a C12 demo project.
See here

I can also confirm the performance issue with the group tracks, using a C12 demo project.


I just posted about the same issue cubase 12 crashing after update… Can only use in a new session. 12 has become worthless…

A post was split to a new topic: Cubase 12 hangs on startup and closing

I personally haven’t had issues upon startup but it seems to be a regular thing with a lot of other users., can vouch that crashing became far more frequent after updating to 12.0.10, I don’t remember a version being so undercooked since C7 which gladly I avoided by running 5, I have a few friends still running SX3 on Windows 7, Bombproof!!!

1 Like

I generally have not seen Cubase 12.0.0 or 12.0.10 crash. While I got the “Freeze”-related startup messages about abnormal termination of the previous session frequently in 12.0.0, actual hangs were quite rare (though I did have a few, mostly just after loading a project when I first tried to play it, generally after having been doing something else while waiting the long time for Cubase to start and load my project – times for this seem to have increased since version 12). Since updating to 12.0.10, however, hangs have been relatively frequent. In the course of two days of use, I have thus far had 4 or 5 hangs.

Two of those hangs were on trying to exit Cubase after having closed the project and waited for the red color to appear when hovering over the Windows 10 close button (the main “trick” that seemed to significantly reduce the occurrences of hang on exit in Cubase 11, and probably also in 12.0.0). I should probably note, too, that I’ve probably only exited Cubase 12.0.10 using the close button a total of 4-5 times, and the times it didn’t hang the exit was shortly after starting the session, just to test if it would hang or not.

The other two or three hangs were when I was playing back a project and made some sort of plugin settings change. For example, in one case yesterday I was trying to change drum kits within Superior Drummer 3. I don’t recall the specifics of the others at this point.

I am on Windows 10, and both the operating system and all plugins are fully updated. My system is not exactly new (I think 2014 vintage – an Intel i7 5820k CPU with 16 GB of RAM, NVidia GeForce GT 640 display adapter running 2 monitors, and MOTU 828x audio interface running over Thunderbolt II), but this frequent hanging is new to 12.0.10.

I have provided a DMP file for the latest hang on exit last night via the instructions Martin Jirsak posted (yesterday?) in another thread in this forum.

I’ve only had the 1 crash while freezing, the majority of instances were whilst working in group tracks or as you touched on previously changing between plugins. there have been several other incidents but really who gives a shit when and where they occurred it makes no difference to the fact that the current release is an absolute abortion,
on a side note in my case it wouldn’t matter if C12 was fully functioning free of issues as I run a UAD PCI and the software isn’t supported because cubase have dropped VST2 Plugins, what is most shocking and annoying about the whole ordeal is the fact a massive company such as UAD who surely would have seen the writing on the wall a Loooong time ago have not only failed to integrate VST3 software into their arsenal, they have no beta running AND absolutely no answer as to “if” or when the issue will be resolved, it’s pretty piss poor considering how expensive UAD is, anyway that’s my rant for the day lol

1 Like

My Cubase 12 with latest update hangs upon closing and when i try to load a project it will then crash over and over… Cubase 12 is trash… One big joke…

Not wrong, about as useful as a knitted condom

1 Like