Cubase 12.0.20 maintenance update available

April 27, 2022 – The Cubase 12.0.20 maintenance update is now available. The update introduces some improvements to the new MIDI Remote integration and also a lot of fixes and enhancements in other areas of the application.

The update can be downloaded in the Steinberg Download Assistant and on the support pages: Cubase 12 Updates and Downloads | Steinberg

Please have a look at the release notes for all details: Cubase 12 Release Notes | Steinberg

If you are still experiencing performance issues after the installation of Cubase 12.0.20, please let us know here: Cubase 12.0.20 performance issues - #2


Congrats on the hotfix


The download link is wrong at:

It links to:


I would like to download Cubase 12.0.20 Pro please.

A post was merged into an existing topic: Cubase 12.0.20 performance issues

Thanks! Fixed!

1 Like

Thanks for this update! Huge difference on my both Windows and Mac systems - earlier the asio performance meter was really unstable even with an empty project.

Macbook M1 Pro 16", 32gb ram, late2021, OSX Monterey
PC i7-6800K, Win 10, 32gb Ram, RME fireface 400

Earlier it was quite unstable at 512 buffer, but much worse at 128. Now looks stable on both


Thanks for the update, very rapid. There’s a few fixes here that were becoming an annoyance for me, so very much appreciated.

In regards to MIDI Remote: I Wish the focus quick controls could have pages, as discussed previously - Is there any plan to look into this?

Look forward to trying this later.

Edit: Couldn’t wait, I had to see what the selected track option on the MIDI remote was like, and it works great with the 5 minutes I had trying it.

Anyone not sure how to use it, I posted a reply on a relevant topic here:

Very pleased with this!

1 Like

It also hangs on startup and shutdown.

Thank you @Steinberg for that speedy update.
Will test the (hopefully) improved and useable again MIDI Remote tomorrow.

Have the Control Room bugs been fixed for MIDI Remote?

1 Like

Still have to open the left hand zone
I open an audio file to get to the tools you’ve worked so hard to create :wink:

Still unable to load audio track presets :frowning:

Bug report: Impossible to load track presets or resize the preset window - Cubase - Steinberg Forums

Sorry, I cannot reproduce this. Under 12.0.20, the track preset window opens normally.

1 Like

Using transport shuttle from midi-remote controllers did not get solved.

Looking forward to try the update and check VEP performance improvements.

Was remote control fixed in the regard of the Control Room?

Thanks for having this update coming soon!


Since the v12 I have always the same problem with an interminable scan of the VST3 and I’m not the only one who have that issue … Last elapsed time of start Cubase : 6 minutes 30 before to have the hub appears !!! and with the v12.0.20 … it’s a nightmare really ! I have opened a ticket with Steinberg but nothing for the moment I have x times deleted my preferences etc … I hope they will have other idea to save my situation …
Gigabyte Z390 Designare i9 9900K with 32 Gb RAM and all on SSD for the data we can’t say it’s a little machine which have no cpu power !!!
I had another issue which was close cubase = freeze and I was able to solve it by change the launch of cubase by mode administrator, now Cubase closes properly

1 Like

NI Massive X still has ‘halo’ around it. Click ‘QC’ twice and it goes away. All other NI Instruments seem okay including the original NI Massive.

Not a biggie for me, but just reporting for the sake of continuity and problem solving …

1 Like

Waves Vocal Rider also has the halo, but this time QC doesn’t fix it.

Just sayin’ …

1 Like

Suddenly Cubase 12 started to hang on startup today. It have worked flawless since I installed it. I feel like there is an issue with the licenshub or something like that. I also installed the update to 12.0.20. Same thing happens! Could not have been a worse time this happend. And I just got my self a new Moog today :smiley: I want to make music.

EDIT: The same issue is with Cubase 11. Also hangs on startup.

I had the same thing happen to me earlier, not had an issue with Cubase starting up in the past - but with 12.0.20, second time I went to use it - it just refused to start, even in safe mode.

Restarted my machine and it was fixed - so make sure you try that. In my case I think something had just locked up in the background I guess.