Cubase 12.0.20 performance issues

Will do. Just FYI that plugin is installed on my machine and I only tried it a few times recently but never actively used in any of my projects, not my favourite anyway.

In the mean time, I have used Pro11 for 4 hours this afternoon without any problems, not a single crash.

Just FYI, UVI Workstation had an update a couple of weeks ago that finally added VST 3 support, in case you can try.

Same overload problem with Superior drummer 3 when multi output and start to mix and add plugs. But I guess SD3 could be the problem too (vst2 and crappy built)

I decided to install C12 again and play around a bit with the latency settings on the Yamaha drivers… It turned out that on the standard settings and latency of 11 ms Peak indicator was jumping and was not good . I changed the settings to Low Latency 512 samples and it is now good … Latency at 12 and 15 ms. However, further when adding a MIDI track while playing a project, there is a short pause … Also, some plugins like Omnisphere sometimes open in an enlarged window…

Posted this in another thread already.

Tried the recommendation of disabling Hyperthreading AND changing the system performance from “ background services ” to “ programs ” and I got around 10% difference on vst performance meter.

I’ve tried again in the past disabling the HT option but there was no difference, so I suggest for anyone who wanna give it a try doing both.

1 Like

Hi @ivic ,
I think you are experiencing two distinct issues:

  1. Performance Meter Peaks

At the opening of cubase with 64 buffersize the meter “peaks” moves a lot even without activity

Cubase 12 uses a new designed performance meter, and shows more accurately the state of the real time communication of your audio card and Cubase. Here’s a more detailed explanation regarding the new performance meter:
(see this post for the details: Cubase 12 Upgrade ASIO-Guard Issue - #147 by Chriss)

  1. Plugins in the Control Room main out: We will investigate this, as there are several reports regarding performance and control room. I hope we can analyse and address this issue soon.

You are 100% right and a guy from Steinberg Fabio has sent me a mail.
I noticed certain Synths especially an Arturia JUN 6V was sending Cubase red with just a few notes played. I used the default lead sound on this synth .
I tried what you said and you are 100% right . Disable and enable and then i could put my whole arm on the keys without a glitch or hitting red
Also Korg Wavestate shows very high nearly touching red when no sound is played .
When you start to play the average and peak levels go down. Another strange thing.
So now we know there is a problem.

1 Like

Still Running higher on the CPU than in Version 11 keeps peaking I have to max out my sample rate on the Interface to run the same project I would run on 512 in version 11.
New remote keeps losing the assignments on a few knobs and slider, I have to keep re- assigning them. had to tweak( lower the quality) haliosonic settings to get it work with lower setting.
still crashes every time I close it out get that safemode screen everytime

1 Like

Thanks for confirming it, thought it was just me singled out :smiley:

Fabio is on the case

Hello Matthias,
Thanks for this update, I’ve noticed some performance improvements while still having random freeze on exit forcing me to kill Cubase in the Task Manager, a dump file has been sent to you, hope this helps.
I’m going to check if justinw227’s procedure can help to get rid of this issue.

Kind regards,

Cubase Pro on Win10, Intel i9 9900KS, 32Gb ram, 4Tb NVMe PCIe M.2 SSD, graphic card GeForce GT-1030

Hi @Rob_Two ,
thanks for your info regarding the performance improvements. The freezes happening after Cubase was sitting for a while (8 h, overnight,…) should be fixed in the next update. Do your freezes fit this description?
Thanks and have a good weekend!

So I finally got the new version to play a decent full session without any drops.
Apparently something has changed with the graphics performance, so it requires using the high-performance graphics card (at least on my Mac).
In order to do that on MacOs, you can follow the instructions at Set graphics performance on MacBook Pro – Apple Support (UK).
Hope this helps.

Hello again! I wanted to ask what can I do so that when I play back even a small project, there is no crackling when I select any track with the mouse? The problem with the PEAK pointer jumping is solved, but in the latest version of Cubase I can hear crackles when I select any track with the mouse during playback…

@Paul_Tumelty There is still a lot of old (and no longer accurate) information on the web in posts (and even some companies’ knowledge bases) listing disabling hyperthreading and c-states in your BIOS when it comes to optimizing your computer for DAW use. There was a period a few years ago when it actually helped in some cases, but processors have evolved since then.

There might be specific situations where disabling hyperthreading might improve performance, theoretically, if you have a CPU with a bunch of cores and a DAW project with very long insert chains on individual buses and tracks, disabling HT could devote each core’s total resources to these very busy individual threads. But as a general practice, you should just leave that stuff alone. Modern processors are much more efficient than they used to be when it comes to both threading and power management.

Depends if you have an OC system. I would always turn off c-state with my OC because when the system reduces power it can cause instability. With an OC I don’t want efficiency, I want raw power. Having a foot long radiator helps of course lol.

Hyper threading I have always kept on.

1 Like

My system is a iMac 2019
With The newest Mac update
I have the following issues :

Ara Melodyne
-Various glitches then applied

  • then I use Melodyne in ara, and after that hit record then shows “recording problem” so I have to remove all ara instances and then I can record some vocal tracks
    In cubase 11 all works but since cubase 12 it’s over. In 12.0.1,12.0.2 also

PC running Windows 10/AMD 5900 3.7/32 GB/ASRock X570 Taichi/RME Fireface 802/RME OctaMic II.
Vast improvement with .10; then .20. This latest revision feels really good.
I’m impressed with this response by Steinberg to problems with C12 on certain systems. Bearing in mind that many users had zero issues. It’s a solid comeback. They deserve some respect for this.


Thanks a lot RTT1,
deactivating the c-state in Bios was really helpful for me!
I even deavtivated the mode for optimized audio performance in CB12 studio settings and switched to 64bit float, HT on in CB (and Bios). Now i can record-arm a track without peaks.
My specs: Win11 21H2, Intel i710870H, Asio4all and Nvidia studio driver (without Geforce experience and PhysX).

Just in case this might help anybody else


Hi Chriss,
If “sitting for a while” means open without using it, that’s not the case but actively working on a project for many many hours, that could happen. The last freeze was related to a quite short session.
This isse was also happening on the previous 11 release, in fact but that didn’t bother me too much, since my work was saved and everything was working fine when I reopened.
I have noticed a longer delay when I save the project and when it allows me to access to the scroll menu in order to close the app.
I had originally thought that after 60+ tracks it would take a while to register all these events, but the latest project is still in its beginning stage so I realized that it’s not due to the load.
Anyway, thank you very much for your excellent support.
I also wish you a very good weekend.

1 Like