Cubase 12.0.20 performance issues

9 posts were split to a new topic: Issue with recording Midi tracks From the Yamaha Genos in Cubase 12.0.20

Thanks Chriss!
Yes I saw the more accurate performance meter.
in fact the most important problem is precisely that of the plugins in the control room, thanks for trying to solve them!

1 Like

I tried to resize Komplete Kontrol window then got a mad screeching sound like feedback but could not stop it until I removed the track. Most companies hire beta testers. What do I get for free now? :rofl:

Hi FilterFreq,

I was also experiencing the same issue, but got it to work by forcing Cubase to use my high-performance GPU (Cubase 12.0.20 performance issues - #75 by rschust).
I know how frustrating this is, and while this is still far from being an acceptable solution, I can at least use C12 for now.
Hope this workaround helps you as well.


This is weird because Cubase isn’t even GPU accelerated.

Well, in the case Cubase would eventually use the GPU, then why it doesn’t report any GPU usage in task manager ? And also why does its frame-rate decrease drastically when playing big projects ?

We now have plugins that are GPU accelerated, for example Melda, that can go up to 100 fps, and don’t bottleneck when playing big projects. They remain smooth in all situations.
Cubase instead has a fixed frame-rate of 60 fps and makes auto-scroll stutter on screens with higher refresh rates.

It is clear that Cubase still renders its graphics on the CPU and not the GPU, but then why is it still necessary to run it with the dedicated GPU ?

Maybe only a developer could have the answer ?

1 Like

After updating to Cubase 12.0.20 in Windows 11, my display is flicking. Cubase stutters when playing back and a plugin window is open. I use others DAW and the flicking doesn’t happen. Steinberg fix this please. Thanks.

Yes i am working with the latest update.

yes they are, I got that issue solved with this update.

Danke Viele, Matthias


  1. I have what is now considered an ancient systems: Win 10. i4770k Sandybridge. RME 9654. And 2 UAD-2-Duos. (At some point, it just stopped being necessary to keep upgrading. :slight_smile: )

  2. Every version of Cubase since the shift from ‘SX’ has been rock solid. -However- it has -always- suffered from hangs after the machine goes to sleep overnight. I have to reboot and there is no error log. That has not changed in C12 and I did not expect it to.

3 12.0.20 is an improvement over 12.01 in several regards., Previously, there were several predictable, if not 100% repro errors: a) inserting or activating a plug-in during playback. b) editing Audio Parts might bring up a constant “Create new version?” dialogue. Over. And Over. And Over. That seemed to have improved.

  1. OK, remaining issues?
    a. The new feature where one can use an Extension on a -track- is unreliable. It doesn’t throw an error. It just doesn’t do -anything-.
    b. On traditional audio events, Spectral Layers is so flaky I don’t know where to begin. The zoom stops working. The various edits don’t do what they should do (although it will work fine if I run SL as a stand-alone,) Ironically, however, Melodyne is completely reliable.
    c. Various settings seem to be getting ‘forgotten’. ie. Key Commands I’ve used for years simply become ‘unassigned’. I re-save them, but that has -never- happened before in 20+ years with Cubase.
    d. The remaining thing currently is that the video is ‘shaky’ at times. During zooms or scrolling sometimes it looks like a jitter effect from an MTV video. Not catastrophic, but annoying.

FWIW… The communication here is the best I’ve seen in 15 years. Well done to all.


I just verified this on my system. A small correction though. The path is to the user who owns the Cubase installation. In my case its: C:\Users\jkswe\AppData\Roaming\Steinberg

The specific folder I removed (moved temporarily to the desktop) was the \Cubase 11_64 folder

After removing it Cubase 12 closes properly without hanging. I can put it back if I need to run Cubase 11. So far 12 has worked pretty well except for hanging on closing.

Oh yeah sorry. Running Cubase 12.0.20


Hi Rob,

Could you please sent me a freeze dump in a PM?


Let’s keep this constructive. We are here to help. What are you system specs? Asio Guard and Buffer Settings? Could you provide us with the freeze dumps please?


Well since you asked for good news, I had a good surprise when I upgraded to this latest release. Finally we are able to use MIDI remote based on track focus (the same VSTi can be controlled in multiple tracks), thanks to the “Selected track” focus added in MIDI Remote…
I can now control hundreds of complex VSTi parameters on any number of tracks.
Thank you very much, Steinberg developers !
btw if you’re interested check this video that shows how to control hundreds of Pigments VSTi parameters (with their names displayed) using a McKie clone control surface and latest 12.0.20 release of Cubase…

1 Like

My systems an old system ( in my signature) so i don’t expect much resolve here , ive tried all ASio settings and turned on and off and any other setting of 1024 on my RME will not even load and play a project that would be ok on 512 and i must add those 10 track are only audio , no VSTi’s loaded which i could load in 12.0.0 , maybe the whole Atmos integration is just to much for my machine which now leaves me with a dead horse . can’t go back to the 12.0.0 due to freezing and can’t move forward due to being an old machine .
Back to 11 it is .
System spec
P8 Z77v pro motherboard
3rd gen 17 3770k
Corsiar 1600lp 32gb ram
4 x Samsung SSD’s
HD 7790 oc graphics with up todate drivers .
This is the first update in all these years im having issues with by the way , yes i know its an old system built to Steinberg recommendations all those years ago , if you would like to give me another recommendation of a built to run Cubase in the future please do and i will build to your spec again .

Hello @jkswenson glad it worked! You can copy the old one back after you have setup the new one.

Same problem here, but on iMac Pro

The update has fixed the problem on my MacBook Pro 8GB Ram. Previously a VST instrument would suddenly spike causing audio dropouts and crashes. Running smoothly now with hardly any load.

1 Like

Hi @Tony_ST ,
selecting a track (in default settings) enables the record button on that track. If the track happens to be a MIDI or VSTi Instrument track, a record-armed instrument is automatically turned into real time processing (to allow lower latency for your live input monitoring).
The real time processing means that your CPU has to deliver processed audio in very short time frames (eg. a buffer of 64 samples/ 44.1 kHz: 1.45 ms to deliver, compared to 11.6 ms when not record-armed).
If you don’t need your tracks being record-armed automatically, you can disable this in your preferences. Still: if you manually enable record on a VSTi track, this track will be processed at low latency, which can lead to overloads/ crackles, if the buffer size is too small for the actual processing load.

Not so long ago, I built a new computer by putting the best I could into it. Very efficient processor, 64Gb RAM etc.
Since then, the computer worked fast, efficiently, and without any problems. The projects with Spitfire, VSO, and Kyescape, for example, did not pose any problems for the processor.
After installing C12, suddenly something started to happen. The fan (I have liquid cooling) works constantly. When enabling eg Spitfire Appassionata, I have to change the audio interface buffer to its highest value, at which, of course, due to latency, there is no recording option. By checking the performance, the CPU is working at the level of 12% or a little bit more.
HDs (all SSDs) are also not running at “high speed”. However, the audio performance meter behaves like a madman - everything on red, and the audio starts dropping.
Have any of you experienced the same? Is there a solution, maybe someone would share the method to improve efficiency?
Intel Core i9 9th Gen - Core i9-9900K Coffee Lake 8-Core, 16-Thread, 3.6 GHz (5.0 GHz Turbo) LGA 1151 (300 Series)
GIGABYTE Z390 DESIGNARE LGA 1151 (300 Series) Intel Z390 HDMI SATA 6Gb/s USB 3.1 ATX Intel Motherboard
CORSAIR Vengeance LPX 64GB (4 x 16GB) DDR4 3200 (PC4 25600) Desktop Memory Model CMK64GX4M4B3200C16
Windows 10
UAD Apollo x4

1 Like

Hi all,

Thank you for all your feedback so far. We are already working on fixes for specific issues for the next maintenance update and we are also further investigating the other reports.

There are some indications that a lot of the performance differences between Cubase 11 and Cubase 12 are caused by old CPU generations that are not supported by Cubase 12.

To get more information it would be helpful if you could send us the Plug-in report which lists the details about your system and configuration.

Please open a project that performs worse in Cubase 12 than in Cubase 11, open the Plug-In Manager, click on “Plug-in Report” at the bottom and sent me the report in a private message here in the forum.

Your support is highly appreciated.


1 Like