Cubase 12.0.30 Pro Licensing problem

I have a legitimate upgraded (from 11pro) license. It has AGAIN failed at license validation stage when I start the application. I logged out and back in to the download assistant. After 10 mins I can get into Cubase. This intermittent fail-out is very annoying. Steinberg fix this, Never got this problem with version 11 and elicenser,

It’s not really possible to understand what is wrong with the info you provide here. Are you running Cubase only, or do you have other Steinberg licenses as well?

By the way, It’s the Steinberg Activation Manager, not the Download Assistant that manages your activations and licenses.

Thank you for your reply Steve. This is a new issue caused by Cubase release 12 licensing. I never had this issue with v11/iLok. I have purged all previous Cubase versions reinstalled swept my Registry and still get this intermittent problem. All other services and systems work ok. My theory: This points to a problem with the license recognition on your validation server. I run a v fast internet connection that is reliable. I see Stef Hofman/DDutch posted the same problem on 29 March. Steinberg are losing goodwill on this.