Cubase 12.0.40 Rosetta confusion

after update to 12.0.40 I need to run my Mac M1 under Rosetta otherwise 3/4 of my plugins and my midi controller Native Instruments KK MK2 are not recognized.

Steinberg…how could this be considered an “update”
can anyone advise how I can roll back to 12.0.30 please?

nice update Steinberg!


On Mac, you cannot roll back. You have to delete Cubase 12 from the preferences folder and install Cubase 12.0.30.

Are the mentioned plug-ins M1 native?

there was a known bug in the first Cubase 12 Releases, that Rosetta was switched on without being shown. Maybe you were running Cubase 12 in Rosetta mode all the time and all of your plugins worked fine even if they were not M1 native. Now with the 12.4 Update Rosetta was switched off and all your non M1 native Plugins don’t work anymore…

1 Like

No, Cubase ran natively, I had to run Logic in Rosetta for the ni controller to work

@pmcc1120 do you have a few example plugins ? Maybe I might have the same and can verify.

I have M1 running on mine.

I updated to 12.0.40 yesterday but i have only tested a couple of projects and all was fine. But thats not much of a test i did.

As far as i can tell Native Instruments only promise that Kontakt works on an Apple Mac M1. No other items unless your in Rosetta.

If you could see any other NI plugins before then you were in Rosetta.

I have Kompete 13 Ultimate and i can only see one plugin and that is Kontakt but its always been like that. Well since Kontakt 6 came out for M1 a few months ago. NI have no other plugins that work native in any DAW.

how do you know? Honestly. I was running Cubase 12 in Rosetta mode for about 2 months thinking it was running natively M1. It even did show Rosetta to be switched off although it was on. If your NI controller was detected you were running Rosetta without knowing it…

1 Like

@jazztom your correct, as i remember I had to switch it to Rosetta then open Cubase and then close it and untick Rosetta to get M1 native. With version 12.0.40 it now says on start up which mode its in which is better.

I did that change when C12 first came out and was i surprised to have hardly any plugins available lol looks much better these days of course.

installed 12.0.4 and while Rosetta is off with get Info on app, during splash screen it says Rosetta right after ver #. so is Cu actually running in Rosetta ? reinstall or ?

You can fix that by following these instructions:

I’ve renamed this topic. The topic starter was most likely running in Rosetta mode from the start without realizing it.

1 Like

thanks but thats not the fix. Rosetta is OFF, but Cu appears to be launching it Rosetta mode anyway.

Did you try the steps in the article? It’s describing exactly that issue.

I"ve said 3 times, Rosetta is OFF. how would I know that if I hand’t of did this very first try because I already know about this setting. its not anything that new anymore. not sure what is unclear about this. there appears to be a lower level bug where this setting is being ignored.

@SteveOakley Have you ticked the Rosetta box in Get Info tab. Currently it will not be ticked so tick it.

(Note: right click to Get Info tab from the icon in Apps not any desktop icons)

Then opened Cubase 12. Then close it and go back to the Get Info tab and untick Rosetta and now open Cubase 12 again.

Now your in M1 native mode.

Everyone has had to do this.

1 Like

Sorry, but I can only know what you tell me. The “Open using Rosetta” box is always off by default. Only now did you specify that you already tried turning it on and off. I’m trying to make sure because that’s the fix that worked for everyone else.

Try the steps posted by @RTT1 . If that somehow still doesn’t work, a computer restart should do the trick.

1 Like