Cubase 12.0.50 maintenance update now available

Unfortunately, I’m still getting random (i.e. non-reproducible) freezes when I load a project (Cubase will freeze after it loads a project - it’ll render all the windows properly but will then become unresponsive and I have to kill the Cubase process with Task Manager). If I then restart Cubase, the project will load and run just fine. Like I said, random. Here’s a crash dump from when it last happened.
Cubase 64bit 2022.11.3 (1.5 MB)

Thanks for the update!

The remote’s going in a very good direction! One thing that stood out for me was the “Inserts Viewer” section. What an interesting choice of words. Not just Inserts, or Inserts control, but viewer. Could this mean we will be able to view plug-ins in a single place in the future? Is it just runOfTheMillVariableNaming? Who knows!

@Matthias_Quellmann , you wouldn’t happen to know anything about it, would you? :grin:

When you have a fade on an audio clip, holding CTRL+ALT while resizing will keep the fade start/end point at the same place, instead of moving the whole fade as you resize. Incredibly useful.

The 2 bugs they fixed regarded it were very noticeable and annoying, so I am happy they have been fixed.

I installed this update and now one of my projects with 2 tracks is unable to play back with 64 samples in realtime on my RME USB interface without crackles and pops. Tried a few different drivers for my interface (v3.27, v3.28, and the beta driverkit driver) all with the same behavior.

Basically the session has SD3 on one track, and kontakt 7 on another track w/ Shreddage 3 archtop, before the upgrade I was able to run at least 3 kontakt instances in this session with no issues. Wonder where this performance hit came with the update.

M1 Max / 32GB RAM / 1TB SSD

I fixed it, had some weird behavior where the Kontakt track recording was getting record armed while playing back. This was getting flipped on whenever cubase was playing into the loop section, whether or not i had looping turned on. Saved plugin settings and started a new project and this cleared up. Weird to see but was able to resolve.

That freezedump lists “wdmaud.drv” hints at an audio driver related issue. You should contact support with the details. Steinberg USA support contact – Steinberg Support

1 Like

So… can we hope to see version 10.0.60 with more fixes?

In all previous versions The maximum was version 05

bug blank news hub if you do not use elicenser still exists in 12.0.50. I added to the wiki several months ago, but it’s not there anymore.

btw I value the work Louis_R, the moderators, and all people who help on this forum. :+1: So no need to attack them


Will we ever get an update where you aren’t penalized for not backing up your preferences.
How did that onus manage to now fall on the user?
It’s the little things that get so frustrating because they go on for years…
Now I gotta spend time on doing the folder dance to get my preferences back…
Really, If there was an alternative rn I woulda bailed already.

1 Like

@Louis_R - I’ve only just seen this:

:clap: :clap: :clap: - Louis - the title of the WIKI is not editable by other users. I don’t know if you want to change it to reflect 12.0.50 ?

@Romantique_Tp @steve - can we make this a sticky - This is meant to be a USER forum and this is one of the most comprehensive, useful and well presented posts I’ve seen here… ever

probably worth copying to the Nuendo forum too


Yes please.

1 Like

Thanks Steinberg for this version.
It now runs ok and fix for midi display is welcome, the others I will discover.
But when I restarted my Cubase 12 Pro after the update, opening my last project, I encountered a strange situation : when I pressed play to listen to my last recorded tracks, my monitors started to yell and I add to hurry taking them off-line, fearing to break them or my hear :frowning:
I had changed nothing in the project saved in without problems previously and with a normal output level.
I am running W11, Scarlett 18i20 3rd.
I had to quit Cubase, restart my Scarlett interface to get rid of this situation, after everything was ok.
What could explain this ? It seems to be related to my Scarlett’s driver, something changed by the update ?
Am I the only to have experienced this.

Referring to @Louis_R 's bug wiki? Big +1 for that!


Blaming it on the system seems to be a go-to response unfortunately. The software should be designed to better cope with difference in hardware/OS.

I’ve experienced 100% more application disappearances/crashes and lock-ups with Cubase since I got back on board a few weeks ago (sold my 10.5 licence back in 2020), than I have with any of the competitors, with which I’ve had zero problems of that nature. It points at the application, not the system in so many cases.

One of the lockups I’ve experienced seems to be related to daring to have a external USB drive connected. This sort of thing is pretty unforgiveable.

You all starting to sound like a cult , i made one remark about how this individual chose to tell someone that his computer was still liable to crash and freeze and you all form a cult . . That is negativity towards a company invest i in with no Facts to follow his comment .
So you can all have you appreciation society but i only come here for my software use .

Have a good day Ya’ll

C12.0.50 seems to be working fine for the things i use here as stated yesterday

Personally I don’t see that Louis or anyone pointing out bugs/issues is ‘negativity’ - it’s incredibly helpful.

And to be fair - Louis has been very carefully and diligently documenting the various bug reports and issues - including CAN references (and therefore logged as ‘official’ and repeatable issues) . To me that as close to ‘facts’ as you can get on this forum.

IMO they should be paying him for his time :slight_smile:


Did the grid lines get fixed with notes going off ??
I have not updated yet as i want to hear how things are going

And what exactly was the problem here? Did you take off the drive, but have stored project data on it?

In case you store data on external USB or network drives Windows is pretty nasty in terms of timeout in detecting a drive that has been disconnected. This is a Windows problem, not the application.

I have one USB disk and two network drives (one of them even encrypted) connected all the time and no lockups at all.