Cubase 12.0.50 maintenance update now available

Tried to create script for Behringer X-Touch and is still hit and mostly miss, unfortunately. And why would Steinberg provide scripts for the very old and very simple controllers like the Akai MPK 249 and not for a dedicated and complex controller like the X-Touch is beyond me. Unless it’s because they know their implementation is still lacking?


So far very smooth without a crash but still has the Mixer GUI glitches which are a strange red line when clicking, and hiding the bottom by the horizontal scroll bar though.

Not exactly : I remember having seen (and installed) a 10.0.60 update.

Beside this, no issue with the 12.0.50 one, so far. Still have to test the MIDI Remote implementation improvements, though, as it seems to having been the main point of this update.

1 Like

Exactly, and the reason to wait 3 months for fixing the midi alignment issue, seems midi doesn’t matter much anymore , not being able to see your notes you have just played live in the correct position isn’t important anymore, as long as you can twiddle a knob on a 94 J copper controller, that’s alright jack !

Thanks - yeah, I saw that in the stack trace. I’m using the Yamaha USB audio driver, so it’s all in the family :slight_smile: I’ll file a support ticket.

Installed smoothly on my intel MacBook Pro, very quick to read vsts, and ran two 12.040 projects as smooth as butter. Fingers crossed, great start. Thanks.


1 Like

No. Nothing Cubase or audio-related on it, not disconnected, not being used. Cubase freezes randomly requiring a full reboot. If I safely disconnect the drive and turn it off, it doesn’t happen. Again, never an issue with any other application on my system, just Cubase.

It seems to be related to this (although I’m on Win11 and don’t leave the app open for long periods.

turns out it was editable - I must have been holding it wrong :slight_smile:
thanks @Nico5 :+1:

(doesn’t bump it though - now bumped too :slight_smile: )

1 Like


Still waiting for lots of older fixes than the ones they introduced since 12.0

also, still waiting for output settings in the video export dialog to avoid converting huge video files with another app.
Working remote means converting lots of videos to send to directors. Come on Steinberg!

1 Like

Mackie HUI / Xtouch support is STILL messed up !!! you can not access the first bank of 8 tracks 1-8 in the TL, anything over 9 is mapped to ->1. There is a simple off by one error in the bank counting code which is a couple minute fix for some one to change. how did this go out the door ? big bug, affects many, simple fix… ??? ##$@#$@#$@#$@#$!!!

All the other updates and bug fixes are great and really thank you for them. it’s clear you guys are working on controller support so how did this possibly not get fixed ? creating seperate BR thread, really we need this fixed. my controller is semi-worthless and this used to work decently prior to 12.0

1 Like

Thank you Matthias

Works fine on Windows 10 21H2 too: recorded a soundtrack today, zero issues.
Thank you Steinberg!

1 Like

Why did you not fix the MIDI SysEx filtering issue? This broke SysEx echo on my Montage if I have a MIDI Remote script enabled!

Seriously, Steinberg: you’re a Yamaha company. Now, to use it normally, I have to go and disable the controller script. It’s really a pain, and I’ve been waiting for MONTHS for you to kindly fix this!

Can you please, please, address this already? I was so hopeful! I pulled it up just now, and it’s the same problem.

How are you prioritizing your fixes? Because this is getting frankly ridiculous: you added all these new features to MIDI Remote, but you didn’t address a problem that you introduced that was not there previously. Why are you not addressing bugs that you have introduced first? Really, why?

Where are your priorities? Clearly not with customers of your parent company.

By the way: thank you for at least fixing the MIDI part “block style” view in the project window. That was annoying.

But seriously, this SysEx filtering is really obnoxious. There is no reason this should be happening. I just want to be able to use my Montage without having to toggle MIDI Remote script enable/disable. Please.

all working fine here. Thanks for the update.

Hey guys. New user to using Cubase 12 Pro. Trying it out here. Update seems pretty good on Windows 10. Haven’t tried it on Windows 11 yet (later today).

Low latency performance is still awful :cry:

I just filed a support ticket, hopefully the freeze dumps will help Steinberg engineers figure this out.


From my personal benchmark measurements (same benchmark song for all tests on the same system) , C12 performed better on my Win10 21H2 config than C11 and C10.5.
You may have a custom template lagging your songs or it may be a driver update

1 Like