Cubase 12.0.51 (M1 Mac) : Preset Saving is still broken (Retrologue)

Why hello there.

How can it be that after 2 new updates that came out in the last few months, preset saving in Retrologue (and possibly other Steinberg plugins) is still broken?

Whenever I try saving a preset in Retrologue, the preset file gets created in /users/[username]/Library/Audio/Presets/…/Retrologue/User/MyPresetfolder

but it does not show up in the preset browser, search or the Mediabay?

I have a feeling that it is even worse now than it was in Cubase 12.0.40 when it was at least showing up in the Mediabay so I could correct some of the tags and category fields.

But now it’s just useless. I really love working with Retrologue and I want to continue creating new presets - but now I can’t because of this issue.

How it should work:

You click the “save” icon, choose your folder and enter all the data, then continue working. When you search for the preset you just saved, it is supposed to show up immediately within the instruments preset search.

Does this have to do with MacOS permissions? Because I made sure all my permissions are granted under “System preferences” - “Security & Privacy”.

Is there no one else with this problem? I have installed Cubase 12.0.51 on two different macs now and both have the same problem. It occurs with fresh preferences (vanilla installation).

Out of options here. I will yet again create a support request for this and I would really appreciate the devs take a good look at this.

Happy to hear your experiences with this!

Have you checked if the folder you speak of has been added to the MediaBay database?

I wonder why you’ve hidden a part of the folder path? That’s not very helpful when the question is so specific.

ugh…it was so long to write :stuck_out_tongue:

if you persist, on MacOS, the path to the Retrologue presets is

/Users/[username]/Library/Audio/Presets/Steinberg Media Technologies/Retrologue/User/YourPresetFolder

You don’t need a preset folder per se, but I find it handier for collections I make

The preset folder is registered in MediaBay as all other presets that are already inside this folder show up in the preset list perfectly.

My theory is that it is not saving the “Collection” field properly when saving a preset and hence, it will not link it to my preset collection and the file just hangs there as a “ghost”? I don’t know…

I tried this on my main computer, a Mac Studio Ultra with Monterey and a Macbook Air M1 with Ventura.

Have you tried saving a preset in Retrologue just for fun? Do you have 12.0.40…12.0.51 or any of these recent versions installed?

You can just write

~/Library/Audio/Presets/Steinberg Media Technologies/Retrologue/User/YourPresetFolder

It’s strange to see a file path with the word User in it twice. Is that correct?

Are you using an “example” filepath, rather than the actual filepath? (because how can someone test without knowing?)

Can you please answer the question about whether the folder at that exact filepath shows in the MediaBay, and that its checkbox is checked?

No, that path is wrong. It appears to me that you are inexperienced with the mac version of Cubase. Please, only reply to forum topics if you know what you are talking about? Kindly, thanks :heart::eyes:

There is nothing there in that folder. “Steinberg Media Technologies” exists but it is empty. I assume you would be able to put “global” content in there?

On MacOS, you have to put it inside the /Users/Library folder.

I put [Username] in brackets because it is to indicate that you have to use your own username, which you are using when logged into your MacOS profile.

There is litterally a /User/ folder inside /Presets/Steinberg Media Technologies/Retrologue/ - I kid you not. Everything else is at your choosing. In my example, I use the folder “Dreikelvin Retrologue Vol. 1” - which is a folder I just copied into the retrologue folder and all the presets showed up.

Saving into that folder, however - is another story.

It doesn’t depend if you put your preset in a collection/folder or not - the outcome is the same. No preset shows up.

#quick update: I just checked read/write permissions in these folders and they were “read only” and “no access” - corrected that but this changed nothing. I still can’t find my saved presets.

As my profile states, I’m on Windows. But my goal in replying to you is to fix everything. I do understand filepaths, and can troubleshoot Cubase like a professional Cubase troubleshooter. I also understand how Mac folder paths work.

There’s something wrong, clearly. I just want to narrow it down to a reportable issue. Then, I will enter it into the Steinberg bug database. I hope that seems like a good plan to you.

So is this the path to the retrologue presets on your machine?
/Users/[username]/Library/Audio/Presets/Steinberg Media Technologies/Retrologue/[username]/Dreikelvin Retrologue Vol. 1/

Is that preset folder listed in the MediaBay? Is it checkmarked?

Yes I have 12.0.51. On my system they get saved to
%userprofile%\Documents\VST3 Presets\Steinberg Media Technologies\Retrologue\

Which is the location where the SB docs say it should be.

But in your report, the files are not in the path list in the docs, which seems like a good reason to do some more investigation.

/Users/[username]/Library/Audio/Presets/Steinberg Media Technologies/Retrologue/[username]/Dreikelvin Retrologue Vol. 1/

no, you just changed the folder “User” and turned into a placeholder, which is not correct. that folder is literally called “User”.
as you can see in the documentation, the path to the user presets is like it says it is:

But the documentation seems to be incomplete. It doesn’t state that you have to browse to “Steinberg Media Technologies” and then “Retrologue/User” to get to the user presets path.

Like I said before, I copied some older presets into that folder and they show up fine in Cubase.

Clearly, it must be something in the way these presets are saved.

Is that preset folder listed in the MediaBay? Is it checkmarked?

Hope this helps:

But in your report, the files are not in the path list in the docs, which seems like a good reason to do some more investigation.

Incorrect. I stated that my presets are in

/Users/[username]/Library/Audio/Presets/Steinberg Media Technologies/Retrologue/User/YourPresetFolder

Which is only 3 levels in from


as it states in the documentation. Steinberg uses a slightly different taxonomy for [your username] but that should not be the issue should it

Here are some test files I created. These don’t show up in my Mediabay. Can you open these on your Windows system?
I am testing this.vstpreset (3.2 KB)
I am saving this preset in Cubaser 12.0.51.vstpreset (3.3 KB)
testeting.vstpreset (3.2 KB)


I just switched my Cubase to “M1 Native” and the (previously saved) test presets now show up.


  1. Saving a new preset while in M1 Native Mode still does not make it show up immediately in the preset browser in Retrologue. It requires a restart.

  2. And even then the behavior is really quirky: if you open the preset browser and select your collection, the preset shows up in the list but when you search for its name, it is not being found! It shows up in the Mediabay though.

Picture: Preset showing in the Mediabay but not searchable in Retrologue browser:

Seems like there is something weird going on with Rosetta/M1 Native builds


I checked in the facebook group “Cubase Users” and immediately got in touch with a fellar with very similar issues. Retrologue 2 was last updated in January 2022 and Cubase 12 was released a bit later. Not sure if this has anything to do with it. But I too noticed issues with Retrologue not writing the preset attributes properly, making it impossible for the preset file to be searchable. We are still testing this on someone elses setup.

By the way I reported a nearly identical issue some time ago this year and even steve was joining in. Déjà Vu?