Cubase 12.0.60 maintenance update now available

Unfortunately that issue is not included in this maintenance update.

Well thanks for confirming so quickly Matthias.
Any chance it might be addressed in a future update?

1 Like

I don’t understand this fix:

“The reference track is now visible in SynchroArts Revoice when used as an audio extension.”

I’m not sure what problem this is fixing. Assuming the reference track is the “dry” one we apply Revoice Pro changes to … was it “invisible” in some fashion to some users?

My problem with using ARA with Revoice Pro was finding that all my changes had disappeared. Is that related at all to this fix?

Thanks -

Does this mean endless encoders now work with the Midi remote and will map correctly with the Vsti parameters ?

So far so smooth with V12.0.60! but still except for these two GUI issues on the MixConsole though… (Win 10, Radeon RX6600XT, i7-13700KF)


How was this not a priority:

(Render in Place incorrectly renders channel pan settings into audio after the first event when rendering multiple MIDI parts and “Dry” Processing.)
I mean, that is audio getting rendered incorrectly. After crashes, that should be really high on the priority list imho…

And my second most hated bug in C12 (which is a regression from C11), still not fixed. >:-(

I really hope there will be another maintenance release…


You are not in contact with Yamaha, then?


Any chance that wdmaud.drv freeze is addressed?

According to your support team, this is a known issue under active development for a fix, so I’m hoping the fix made it into this release!

Getting error on update. This software is not only broken when trying to use it, now also setup is failing. Anyone knows how to fix this?

Can’t wait to check out the improvements with the extensions (melodyne and syncroarts).

Thanks a lot for “ Focus Quick Controls now continue to work for plug-ins which have been moved to another channel.”
That I’m using it constantly. :pray:t2:


in audio connection sends and mixer sends are named corerctly. but in project view they are messed up something similar to this … >Op# >…also 1 track in mixer view named Bass St is messed up say’s 100op click to right on it say’s drag to copy… just click and name shows correct… click off of it goes back to 100 op. if i use all capital letters in name it shows correct and stays but cap’s is not what i want…by the way i have Nuendo 12.0.60 and It doesn’t have any of these problems

ideally keep it to the same thread ?
(although to be fair I notice this was merged from yet another thread)

That is a Windows Installer Error, caused by problems on your machine.

MSI installation error 1603 - Windows Server | Microsoft Learn

Once again I’m surprised at what was fixed. I wasn’t even aware that most of the items were problems. And this makes me wonder how SB chooses what to fix next? Is it the lowest hanging fruit? Or maybe issues that affect VIP users?

It seems most of what gets fixed are relatively arcane issues that affect few users. A better strategy would be to do what utility companies do after a big storm: repair the downed lines that will restore power for the most users first and then work your way down the grid to those in the most remote regions.

SB appears to do the exact opposite! Large, long-standing issues that affect many users are seldom addressed. Very strange…


What about freezing, staying in task manager? I hope there has been a change here as well.

Thanks, but unfortunately no.

Stating the obvious perhaps, but have you tried restarting to ensure that there’s no file locked or anything?

Also, ALWAYS had this is issue with the download manager. NOW GONE! How?!? Nothing we tried with the support worked for that. Really glad for some reason now works perfectly.

macOS 13.2.1 (soon to upgrade to 13.3). I opened Steinberg Download Assistant and was offered updates for Cubase 12 and VST Sounds. The upgrade to 12.0.60 went smoothly, but SDA gave me errors when I clicked on “Install All” for VST sounds. It tried to upgrade Amped Elektra, B-Box, HALion Sonic SE Basic, HALiotron, and Verve. I couldn’t catch which .vst files the dialogs complained about, but I just hit Ok and they all seemed to succeed.

Then I went in and clicked on Install again for each of those VST Sounds and this time they installed with no errors. Cubase 12.0.60 seemed to start up okay, and when I quit and restarted SDA, it didn’t offer to upgrade anything, so I’m guessing everything ended up okay. It was weird though.

Now :crossed_fingers: that everything will still work after I upgrade to 13.3!

It seems more so that they throw a dart and fix whatever it lands on.

1 Like