Cubase 12 crashes when removing track


Reported to Steinberg. Thank you.

Could you try with the latest Cubase 12.0.10, please?

I have not had this issue with Cubase 12.0.10. Tracks delete without crashing in the latest version.


1 Like


I’m glad to hear. Thank you for letting us know.

I’m having a similar problem. Cubase crashes when I select “Project → Remove Empty Tracks”. Trying to remove about 30 tracks in one shot. Running Cubase 12.0.40, also on Mac Monterey w/ an M1 Pro in Rosetta mode. Log file attached.

Cubase 12-2022-11-17-141544.ips (66.1 KB)

Update: I restarted with 3rd party plugins disabled and it worked ok. Must be something to do with one of the plugins…

I’ve had the same problem for 2 years now, no matter what I try. I have to shut down and restart my Apollo interfaces for Cubase/Nuendo to not crash when reloading after the initial crash caused by attempting to remove unused audio tracks. It’s a nightmare for me because sometimes I end up with 50 or more extra tracks that are just sitting there, that I have to hide. I haven’t found a cause yet. Removing all plugins, no difference. All versions of Cubase and Nuendo since 2 years, no difference. No audio interface, no difference. The problem of course isn’t as bad on smaller projects. Otherwise it happens about 50% of the time, so I usually don’t dare remove any audio tracks. The problem is the same when deactivating them. Same if they have no output at all. Big mystery for me.


Please update to the latest Cubase 12.0.60.

I am getting same problem with cubase 12.0.70 and older version also.
Not happening with all the project
it’s frustrating

Only way i found in this situation is put all empty tracks in folder then close the folder and delete that folder or select “Project → Remove Empty Tracks”

1 Like


Attach the DMP file, please.

Same Problem of Cubase 12 Crash when removing track with Mac Pro M2 ultra 128 Go with Ventura 13.5.2 and Cubase 12 version 10.0.70… :disappointed_relieved:

Hi and welcome to the forum,

Please attach the *.ips file(s).

OMG Thank you thank you thank you pGordy! I had this problem for years, and indeed, unchecking all midi devices in Midi Port Setup fixed the problem. I’ll be back if it happens again, but I tried deleting audio tracks (1, 2 and more at a time) a bunch of times, and I should’ve crashed tons of times by now. Wow, I’m glad I decided to look this up!!!

Nevermind, the problem is back. After writing my last post, I returned to Nuendo and deleted another audio track, poof! Back to the drawing board.There must be a connection with midi implementation though, because the problem was really gone for 5 minutes. I wasn’t able to delete so many audio tracks in years!


You mentioned your issue at least in 3 posts (apart from this one here and here), but you didn’t post any single crash/DMP file. Please do so.

Hi Martin, yes, I was trying to get help from as many places as possible :wink: I have a ton of crash logs. They are easy to generate. Here’s one from June, and one from today:
Nuendo 12-Poof Delete Audio Track(s) 2023-06-20.ips (645.7 KB)
Nuendo 12-Poof Delete Audio Track(s)-2023-09-19-115947.ips (823.4 KB)


Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Or could you try to trash (backup/move elswhere or rename) all Nuendo preferneces folders (even older Nuendo versions)? Nuendo Preferences folders are:
Mac: ~/Library/Preferences/Nuendo X
Win: %appData% Steinberg/Nuendo X_64

Reported to Sgteinberg.


This is a known issue. It happens when the EQ display is visible in the Inspector. First, close the EQ display and then remove the track, please.

After 3 or 4 years, problem finally solved. I’m baffled that I never found an answer before anywhere.

This is so basic. I’m bewildered I was never able to put 2 and 2 together lol.
It’s true that I always have my EQ visible in the inspector. I never thought of changing or removing all items in the inspector! My life is now saved hahahaha!
This one goes down as the most insane bug adventure ever.

Thank you Martin!



Finally, after download the latest updates of Mac Osx Ventura 13.6, for me, this problem has disappeared ! :blush:

Having the same problem. I had it earlier but now it is back. It came back when I used Groove Agent again. I even opened a new project, opened GA and opened an extra audio track. When I try to remove the extra track Cubase crashes. So the problem in my view is the Groove Agent. Updated both Cubase and GA and the same thing happens. Im using M1 with Monterrey.