Cubase 12 crashes when using SpectroLayers on macOS

Hi, just upgraded to Cuabse 12 from 11 and I can’t use the SpectraLayers version that allegedly comes with the software.
Here’s my situation:

  1. I mistakely downloaded SpectraLayers pro 10 using Steinberg Download Assistant.
  2. I tried to use SpectraLayers extention on an audio track in Cubase, and got a no licence message.
  3. I realised that I’m not supposed to have a licence, and that a lighter version of SpectraLayers should be included in Cubase.
  4. Via Steinberg download Assistant I deleted SpectraLayers pro 10.
  5. I restarted Cubase.

Now, phase 2 is repeating itself. I try to use the SpectraLayers extention and get the same error message.

How can I activate the SpectraLayers that’s included in Cubase?

Cubase 12 comes with SpectraLayers 9 One. You’ll find it in the Cubase section of the Steinberg Download Assistant. Before installing it, I recommend to uninstall SpectraLayers 10 from your computer if not done already.

2 Likes

Think @Martin90 nailed it above… :smile:

Uninstall SL10 from your machine - uninstalling via SDA only removes the SL install package from your download location. Running an uninstall of an application locally is a separate thing. Hope that makes sense.

When you relaunch C12 now, you should get SL9 One available (via the ‘Extensions’)

2 Likes

Hey guys thanks for the quick answers.
I am using Macbook pro and uninstalled the app by moving it’s folder to trash and emptying it.
Now i get a different error -


Which I don’t undetstand because there is no longer SpectraLayers 10 folder in the Applications folder.
I also found that I do have the SpectraLayers 9 in the applications folder (btw @Martin90 it is not found in the Cubase nor SpectraLayers sections of the SDA).

It seems to me that once I downloaded the 10 version, Cubase was configured to look for it, and now once I deleted the 10 version, It was not re-configured to search for the 9 One version.

How do I move on from here? Did I miss anything in the uninstallation process / is there a way to tell Cubase “Leave version 10 alone, just search for 9 One - you have it” ?

I’m not familiar with MacOs, but did you close Cubase before uninstalling SpectraLayers 10 and before installing SpectraLayers 9 or haven’t you installed it again?
I guess Cubase needs to be closed before removing or installing components so that all configuration files are accessible and can be changed. I’m not quite sure what you actually did in the meantime. Maybe reinstalling SL 9 Pro will help.

Right, it’s not directly listed in the section on the left side but in the content section of Cubase 12 Pro:

D’oh.! Of course, this is an important last step I completely missed…! Nice one @Martin90

Apologies for (any) confusion from me @Fried_Onion …! And I’m no MAC user either… so no help/clues here, as to that new error pop-up.

Anyway, you will need to re-install the SL9 package after uninstalling SL10 - inside there, Cubase will default to pick up the ‘One’ edition, if it can’t see a license for Elements or Pro available.

Thanks for the replied, now I got a new problem.
I uninstalled SpectroLayers 10 and 9 and restarted the computer.
Then got the same error as in the last screenshot - only mentioning SpectroLayers 9. Allegedly good.
Exited Cubase, downloaded SpectroLayers 9 One and re-entered.

When choosing Extention on an audio track - now Cubase just crashes! The app was closed without any notification.

When re-opening cubase I get this message

Now trying to restart again… So weird, why does it have to be so complicated? love the DAW but messing around so long to resolve simple things as this… well I’ll just restart.

Firstly, hope you chose to send the log file from the prompt above. It can only help further troubleshoot for SB devs.

Second, the error prompt indicates to me that somehow SL9 hasn’t got itself installed properly/fully (there is no SL9 One install as such; all editions are contained in the same install package. The activated license for the machine determines which of them actually runs).

Sorry, out of ideas; you’ll need some other MAC help on this one from here…

Maybe edit that info into the title of this thread to draw MAC folk to look in…? Or, you could update your profile with system info etc… that way, people wouldn’t have to ask/guess/waste their and your time, providing wrong info LOL.!? (click on my avatar picture for an example)
Your Forum Profile - Cubase - Steinberg Forums

Thanks @Puma0382 froe taking the time and the good intention!
Turns out that the porject was corrupted.
On other projects it works fine!

1 Like