Cubase 12 Elements does not work with any midi keyboard

Hello, I already created a topic about this, but no one replied. This was related to issues with the Arturia KeyLab Essential 61 keyboard with Cubase 12 Elements not working. Midi messages were coming in, which was visible in the Transport section, but the sounds of the instruments were not heard. So I installed the trial version of Cubase 12 PRO and to my surprise everything works as it should :slight_smile: So why doesn’t it work in the Elements version??? I don’t need the PRO version and it’s also too expensive for me. I will add that I checked and my Cubase Elements does not work with any other keyboard. I don’t know what to do anymore.

Please upload a screenshot of Studio Setup - Midi Port Setup.

Hello,
I Got all so problems with the Arturia products Sometimes it works but most of the time it doen’t.
Tried to start the PC and looked at de Midi profiles Everthings seems to be OK.
In the Midi Center Of Arturia Everting gives a signal.

In My Case it is happing in Cubas 12 pro. Tried Halion 7 and Groove Angent 5 Both have trouble.


Hi,

I believe there is MIDI Remote script for this device. So the device behaves as DAW controller then. But you should be able to play the keyboard.

Could you provide the Studio > Studio Setup > MIDI Ports Setup screenshot as mentioned, please?

Hi Martin,
It is a strange thing.
Sometimes it works and than it stops out of the Blue.
I try to reload the profiles Arturia Midi Center and disconnect the USB cables.
The last thing is restart Windows 11 pro and than it works again.
This started since the last update

These are screenshots of my settings. These are the settings that Cubase support told me to use. In Elements 12 Transport works but keyboard does not. In 12 PRO TRIAL everything works without a problem. I do not know what to do.
Uploading: Arturia 1.jpg…
Uploading: Arturia 2.jpg…

Hi,

As we can see the device is in use for the MIDI Remote.

Could you attach a screenshot of the MIDI Remote device, please?

Do you want to use the device as Cubase DAW Controller, or do you want to use it as plain MIDI controller?

My screenshots of settings that Arturia support told me to use. The transport works but the keyboard does not. When I press the mouse on the on-screen keys, the instruments play. On the same computer I have 12 Elements in which it does not work and 12 PRO in which it works without a problem. Why ?

And here are the Control MIDI Center settings

Hi,

The “All MIDI Inputs” option is disabled on the @studio.talent side but enabled on the @PascalZorenc side.

That’s what Arturia support told me, but I also checked it with the selected one and it also doesn’t work :frowning: I didn’t even set anything in Cubase 12 PRO Trial, I just connected the keyboard via USB and it works without a problem. I don’t have the strength for it anymore and I think I’ll switch to another DAW. No I’m going to pay this much for the upgrade from Elements to PRO. I’ll add that I also connected the KAWAI KDP 110 to the piano and it’s exactly the same situation. In PRO it works in Elements no!

Did anyone find a solution for this?

Is it a bug with Elements 12?

Or is it the way it is…which would suck the BIG one!