Cubase 12 Gpu Acceleration

Hi all, Why Cubase 12 doesn’t support Gpu Acceleration on windows? Very jagged frames, lock 60 fps looks very bad on windows. I have a 240 gpu gpu RTX 3090 monitor, and would like to achieve smooth cubase work.
I have a Mac and the Cubase 12 pro Mac version has a “Gpu Acceleration” button, once enabled everything becomes very smooth and beautiful. On Windows there is no such button.

For working with Cubase It is recommended that only the basic driver and no Nvidia tools etc are installed. These two don’t cooperate.

If I install Studio Driver From Nvidia will the Gpu Acceleration button appear? I don’t have anything from Nvidia Tools installed


Ummm , there’s something not quite right if you are getting lag but YES , with the integration of Spectralayers 10 (which has Gpu acc) in ARA you would think Steinberg would move in the direction of Gpu support for Cubase 13

Because on Windows you don’t have the option to disable GPU acceleration. It’s always active.

But why then on Windows do I have a maximum of 60 fps in Cubase, and the Cubase does not look smooth? Is it possible to somehow make Cubase run smoothly at 120 or 240 fps?

Have you enabled Preferred Max Performance in the Nvidia control panel ? , I run a lesser card Rtx3060 with perfect results
Have you got HdPi enabled in Cubase ?

I don’t think it has anything to do with fps. When I see Cubase on Mac, things move rather smoothly. On PC Cubase moves everything in steps. Toc toc toc toc instead of swooosh.

1 Like

I run 120hz and Cubase is definitely smooth for me. Which elements are lagging, is moving plugin windows around laggy too or are they smooth?

You may have some specific application settings in Nvidia control panel perhaps that’s locking it perhaps?

I agree it does look and feel smoother on Mac, but it’s not by a massive margin.

I think, that on Windows with ASIO drivers at least, there is a correlation between the ASIO driver latency and the update rate of the various GUI elements, so reducing the audio latency increases the refresh rate of bars/meters etc.

That’s exactly what I’m talking about. It’s all very twitchy.

Pay attention to the behaviour of analyzers on Mac with Gpu Acceleretion enabled and on Windows.