Cubase 12 grace period license problem

Hi, I got my code to upgrade for free to cubase 12.
On my product list I had Cubase 12 pro (pending activation)
Because of your server problems I couldn’t do it, but now I also get
Cubase 11 not upgradable on my product list , Cubase 12 pro doesn’t appear on my Steinberg product list
and when I try to open Cubase 12 pro I get no license error.
Please advise.

Hey, sorry that you are having trouble. Our server is getting a lot of traffic right now. What does it say when you open the new Steinberg Activation Manager?

“loading please wait”

It looks like the update process has completed successfully.

Could you try rebooting your computer and opening Steinberg Activation Manager to check your licenses.

It says cubase 12 pro activated.
Will this be added on my Steiberg product list after you resolve all the issues with the activation server?

The new Steinberg Licensing products should be visible in our new self-service portal here:

Over time, we aim to provide a unified view of all your licenses and retire the old portal.

My license says Cubase 11 (Grace period eligible) on the eLicenser Control Center however the Steinberg Download Assistant has no recognized license for Cubase 12 (only for Cubase 11). I tried to register the license through the eLicenser Control Center to Steinber but there is an empty space where Cubase 11 (Grace Period eligible) should be. Can you assist me please. Should I wait for the traffic to congest? What steps do I need to take when things clear up? Thank you so much!

Hey @Robertj64, please open the Steinberg Activation Manager (SAM) and click on “Grace Period Check”. You will then be guided through the process.

I have downloaded SAM but it does not load. It works through Steinberg Download Assistant. I open that up and there’s Cubase 12 is there but nothing about a Grace Period.

Robert Orzechowski

Unfortunately there is a lot of traffic on our system right now. Please try again to do the “Grace Period Check” in SAM at a later time. Sorry for the inconvenience.

Hi Robert - is Steinberg Activation Manager showing Cubase 12? If so, it sounds like you’re already updated?

Hi Ben
It’s there. I downloaded all the files but it said I didn’t have the license. Will try it again.

Robert Orzechowski

Hi Robert - just to be clear, there are two applications:

  • Steinberg Activation Manager which is used for the new Steinberg Licensing system
  • Steinberg Download Assistant (SDA) for downloading and installing our software (and redeeming your download access codes)

SDA shouldn’t need a license for you to download the files.

Thanks Ben

I cannot open the Steinberg Activation Manager. Not sure why but I read somewhere that the SDA is like the cover for it.
SDA had Cubase 12 in it but it was not under the license choice. I’ll give it a go and download all files? If it doesn’t work, do I need to reverse the downloads?

Thanks, Ben!

Robert Orzechowski

What happens if you try and open Steinberg Activation Manager?

Hi again Ben
SAM actually loaded!! Thanks again for your help!

Robert Orzechowski

Hi, I have problems getting my grace update too. I have the USB-Dongle with my Pro 11 License connected, I run Activation Manager but it doesn’t show me any licenses to update when i do the gracecheck. I bought the 10.5 pro to 11 pro update 01.01.2022. This should work right?

Same problem with you my friend. I bought and activated Cubase Pro 11 in February 9th I have also registered my usb license on steinberg, everything’s perfect for Cubase 11 but when I try to run SAM non license found. I did also maintenance on e licenser but anyway nothing yet. I tried to download Cubase 12 from SDM but when I try to run it finds no license again.

What happens when you run the maintenance task in eLicenser Control Center? Does your Cubase 11 license show as “Grace Period Eligible”?

If Steinberg Activation Manager is saying “no licenses found” when running the grace period check (even when the Cubase 11 says “grace period eligible”) then perhaps you are running eLCC.exe as administrator. Could you check to see if the property has been set on the executable to “run an administrator” and unset it.