Cubase 12 hangs on "checking licenses" splash screen

I upgrade one of my two licensed copies of Cubase pro 11 to Cubase pro 12, using the Grace period.

I am running it on a mid 2015 MacBook Pro with 16GB RAM & 500GB SSD.

Everything worked fine, but now I find, on returning from 2 weeks holiday, that when I try to run Cubase pro 12, it hangs on the “checking licenses” splash screen.

The first time this happened, I had to hard restart my MacBook, as I was unable to force quit Cubase.

On subsequent occasions, I can force quit the app, but it resolutely fails to progress any further than the splash screen.

I understand that Cubase Pro 12 utilises the new Steinberg Licensing system. I have checked “my products” on My Steinberg and it is shown as one of my Cubase Licensing registered products.

The e-licenser shows Cubase 11 upgraded to Cubase 12 with Steinberg Licensing.

Just to be sure, I have tried launching it both with and without the e-licenser.
I have also installed the latest e-licenser software.

I have uninstalled and re-installed Cubase 12 as well as Steinberg Activation Manager & Download Assistant, but I get the same result.

Cubase 11 [on a separate e-licenser] runs fine, as does Wavelab 11, via Steinberg Licensing. [I am not trying to run both at the same time BTW]

The strange thing is that Cubase 12 runs perfectly fine on my iMac under Steinberg Licensing.

I opened a support ticket 12 days ago, posting a full description of the issue along with screenshots, but have heard nothing back from Steinberg Support.

Okay… so I figured out that the issue might be fixable by logging in to Activation Manager.

The only problem is that Activation Manager also hangs when I try to run it. The icon bobs up and down in the dock for a few minutes, but when it stops, no window appears…

Got the same issue just now, but I’m on Windows 10.

Was working on a project, closed it, tried to open another and Cubase just shut down without any warnings. Now, when trying to start Cubase again, it shows splash screen with “Checking licenses…” and just closes.

Activation manager is stuck on “Loading, please wait message” and eLicenser Control Center doesn’t show any licenses.

Connecting USB licenser (I’ve got Cubase 11 Pro license upgraded to v12) doesn’t change anything either.

I have work to do, how to fix this?

Seems like there are some issues on Steinberg side, as there are at least two more recent topics with similar issue:

I suspected this might be a Steinberg Licensing issue.

Unfortunately Steinberg Support seem to be about as much use as a chocolate teapot. I’ve been a Steinberg customer since the Atari days, and tech support used to be okay; at least you could get to talk to somebody…

Now they just don’t seem to care about their customers at all… I’ve been waiting 12 days since I raised my ticket, and the only phone support available involves an international-rate call during a very small window and [quite likely] the prospect of sitting in a call queue watching the minutes rack up.

I was going to buy Spectralayers Pro 9, but on this showing I don’t think I’ll shell out £205 for a piece of software that might or might not work.


A simple reboot fixed the issue for me. Weird :face_with_raised_eyebrow::grinning:

Totally agree. I also noticed their support worsened significantly after Yamaha acquired them

1 Like

Glad that worked for you :blush:
After running First Aid in Disk Utilities, which took about an hour rather than 10 mins, so indicating some severe problems, I even went as far as reinstalling MacOS.
Although this made the MacBook run quieter & faster, I still have the same issue with Cubase 12 and Activation Manager, so I presume it must be something to do with Steinberg Licensing?

I have also just updated to Monterey “just in case”. Still, neither Cubase 12 nor Activation Manager will run :face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

1 Like

Such a shame. I was seriously considering updating to C12P, but reading the forums has been quite eye-opening. I got back on the forums because I can’t even run the demo on my off-studio laptop. No tech-support response in a week and the demo not working makes me not want to risk paying for it (even if it is €99 for the upgrade from C11P). Reading your post stops me from upgrading from Catalina, as I was thinking that the OS could be the issue. Activation Manager doesn’t even go past “Loading, please wait…” and I can’t get past “No license found” when TRYING to run the demo. So basically I have no idea if C12P will work on my setup or with my past projects and plugins. Sh-sh-sh-sh-sh-shame.

1 Like

The weird thing is that C12P runs fine on my iMac [late 2015, 32GB RAM, 1TBSSD] which is also running Monterey.
I’m assuming it must be a glitch in the licensing software implementation on the MacBook, but have run all the Mac diagnostics, reinstalled C12P and Activation Manager etc etc.
Still nothing from Steinberg Tech Support - 15 days now :face_with_symbols_over_mouth:

…so… rooting around on the Steinberg support pages, I came across an article entitled:
“Mac OS X: How to uninstall an application completely” Mac OS X: How to uninstall an application completely
Wondering whether some traces of a previous installation had been left, I followed the instructions to the letter.
I uninstalled Cubase 12 and download Assistant again :face_with_symbols_over_mouth:
I removed all traces of Cubase 12 and Activation Manager as directed- took me about 30 mins but as I completed it I was hopeful.
I reinstalled Cubase and Download Assistant, logged in and as it went through authorising Activation Manager I was even more hopeful.
But I have exactly the same issues: Cubase hangs on the “checking licenses” splash screen and Activation Manager just hangs without even getting as far as a splash screen.
And of course, still no response from Steinberg’s wonderful tech support… AAARGHH!!! :face_with_symbols_over_mouth: :face_with_symbols_over_mouth:

This sucks, man. I can’t go on wasting time trying to make it work. It’s just useless.

Removing all vst2 fixed it for me. I had this issue when cubase 12 launched. Ended up deleting all my vst2 as a last ditch effort. It solved the crashing and no plugin issue.

I got some plugins during summer sales and it started to crash again. I guess vst2 got through. I removed them and it’s back to normal.

I hope this helps.


Okay so thanks to Steinberg Support I have the solution.
Turned out to be some kind of incurable corruption of my User Account on MacOS.
I created a new user account on the MacBook and tried running Cubase from there; all worked fine - Activation Manager opened up the first time and I activated Cubase 12 and Wavelab 11 quickly and with no problems.