Cubase 12 losing Control Room and IO settings!

This is bad.

Reopening projects and the Control Room outputs are gone and I saved a Preset which isn’t showing up in the menu.

Pretty simple luckily…2 Cue outputs one with Click enabled, Talkback

I am going to overwrite the Default and see what that does

You are not alone on this. I had 64 stereo stereo output channels with all custom labels typed in. I saved, restarted, and it is all gone. That is just one of many issues. Hanging on shutdown at least 50% of the time.
This Cubase 12 isnt even Beta ready. I dont care about the fan boys and their praise of CB12. I have a standard modern DAW machine 10700k. Nothing crazy.

I dont have any issues running Studio One or any of my VSTs. Guess what I am doing? Uninstalling this POS and giving up. I am tired of paying for Alpha releases that just plain suck my time.

You dont have to be a “fanboy” just because you have a working C12 installation.
I do.
And I sincerly demand you to not call me a “fanboy”. Thank you.


I’ve been regularly having this issue with Cubase for a while - but 12 also reset everything on me.

Luckily I managed to bring in some presets from Cubase 11 that worked.

I’m still a fanboy :wink:
just not of this update!

So the rest of the day….my Control room settings worked. We’ll see