Cubase 12 New License Engine Backward Compatibility

Hi!

As we know before with the dongle till 11, we could use any older version of Cubase with it. Older version like 9 has the replace audio in video option. I still use it because the video export option is only compatible with 48khz sessions and my workflow in 96khz all the way.

So my question is that after moving to the new C12 licensing could I still use older versions as before?

Yes, but you’ll need your dongle to run them - it will turn into a Cubase 11 “Non-upgradeable” license once you update, and run exactly as it always has done.

Cubase 12 onwards will be on the new licensing system.

1 Like

Perfect. Was just doubtful before activating it. Did it right before your comment and works the way you said!

Thanks!