Cubase 12 new "smooth waveform drawing"

Does anyone know where this new feature is located/activated?

It’s just there by default, if you zoom in you’ll see they’re smoother.

aaahhh, missed that! Thanks:) 12 is great and working flawlessly here.

It isn’t there by default.

It is activated with Interpolate Audio Waveforms in Preferences > Event Display > Audio.

Before Cubase 12, it was simply joining the samples with a curve instead of flat steps when you would zoom high enough to see them.
Now it also adds anti-aliasing to the waveform edges so the pixels aren’t sharp. This isn’t related to the zoom level.

Unfortunately there’s quite a bunch of issues with this new functionality, including making silences thicker, graphical and performance issues in the editor, and MAC users cannot disable it.

It’s a default setting, so you don’t need to activate it. Much like how “Show Waveforms” doesn’t need activating.

The overall rendering of waveforms is overall cleaner/smoother, anti-aliasing being a part of the new routine.

Well, for me it was disabled by default.

Hit the ‘defaults’ button it should look like my screenshot:

You can cancel afterwards so those changes don’t get saved.

Waveform Interpolation is an option that’s at least 10 years old, so if you’ve updated Cubase from older versions, carrying your prefs over I expect that accounts for it. At some point it was probably considered a performance hit and started life disabled?! :slight_smile:

So yes, any longterm users reading this, check that option for sure!