Cubase 12 PRO can't find my UR824

I’m using UR824 along with Cubase 12, but suddenly - Cubase doesn’t seem to find the UR824. I also have Cubase 11 PRO installed, which finds the UR without any issues.

I suspect this happened after I installed Cubase 12 on a laptop as well as the studio computer.

Anybody have any idea on how to fix this? :slight_smile:

1 Like


Are you on Mac or Windows, please?

Oh, sorry. I’m on Windows 11.


Download the latest UR824 Tools and install it as administrator, please.

Have done that.


Have you tried to select it in the Studio > Studio Setup > VST Audio System, right?

Yes, but it doesn’t show up. Only the generic ASIO-driver. And again, Cubase 11 find the UR824 just fine, so I’m thinking this is a Cubase 12 problem.

Also… Cubase 12 worked fine with no issues until I installed a copy on my laptop as well as the studio computer.

Can you not pick the Yamaha Steinberg USB ASIO Driver by using the menu to the top right?

1 Like


One Cubase installation doesn’t know about other Cubase intranational at other system.

Hasn’t any Windows (silent) update happened?

I did do a Windows update, but that was after Cubase 12 stopped working.

You know, it WAS that simple. I knew it was something really simple I had overlooked - it usually is - but this was beyond stupid. But it solved it though. Thank you very much!! :slight_smile:

1 Like

Mac Studio, OS 12.6.2.