Cubase 12 Pro, first time having recording printed lagged (?) on Mac

So, I’ve never had such issue in my whole life …(?) somehow haha

I know some having latency issue and all… but I never understood it.

Also I always wondered why I need to activate constraint compensation thing on the corner…

But yesturday, I opened my friend’s Cubase 11 project (got Guitar recorded) and brought it home, opened it and tried to do some songwriting by recording guides vocal… but somehow, about 10ticks…(?) I can’t explain correctly, but my vocal was being recorded ‘LATE’… like…
so…

I never ever had this issue even with ‘God knows’ how many plugins I always put on without turning it off, ‘because’ I’ve been using UFX and UFX ii all times and monitoring was never an issue… but yesturday I experienced it for the first time lol that, my vocal was being recorded ‘lagged’/‘late’ being pushed to the right a bit.

When I was monitoring I could hear it perfect, but the ‘printed wav’ was out of time, that someone could easily say, ‘hey, the wav seems out of time, a little lagged?’

Anybody having similar ‘random’ issue like me?!

AND guess what… somehow, my own project that I had, (not my friend’s) I tried to record on that project… I am not having any ‘lagging’ print recording issue…!!!

This is random right…?! Issue on Cubase side…? or… my UFX ii…? hahaha…

I don’t know what it is! I’ve always turned on:

  • ticked: adjust for record latency
  • record shift: 0 samples
    volume automation precision: 8 samples

Audio Priority : normal
disk preload 2 seconds

Ticked - activate asio-guard

  • always leave plugins on, because RME UFX ii always let me monitor without ‘any’ scale of latency :slight_smile:

Strange, strange…hmm.

Oh, also, I also always put buffer to the max like 2024…? because that is totally fine with me and monitoring while recording through UFX ii makes it latency-free anyway?

My all -time setting was:

  • Tick on ‘record shift’
  • BUT values there were always ‘0’ and I never had issue like above.