Cubase 12 Pro freezing on startup - fixed

Concerns: Cubase 12 Pro , Win10

  • The Problem:
    Since the release of Cubase 12 Pro, I have had the problem that it “freezes”, mostly on startup when it shows the news/projects window. Sometimes it happened earlier, in the startup window where it is loading plugins, checking licenses, etc…
    It just hangs, and I can’t click anything. Always had to close Cubase by using TaskManager.
    Every now and then, Cubase started normally and worked okay. But most of the time, it kept freezing on startup.

  • Solutions tried:

  1. I submitted a ton of crash reports from within the safemode startup window
  2. I re-installed Cubase, latest maintenance updates
  • The solution:
    I found the problem in the Windows logs. It seems to occur quite often for some Win10 users (while others have no issues). The problem is more a Windows problem, rather than a Cubase problem. So it can affect other software also. In my case I only had problems with Cubase. You might want to check your own Win10 logs, to see if this problem is causing you trouble.

The issue was “Win10 ID 10016 DistributedCom permissions”. Google it for the steps on how to fix it.
In short, it has to do with this DistributedCom file not having the right permissions to access it. I’m not sure what caused these permissions to be wrong. Just something that went wrong during an installation I guess.

4 Likes

Thanks for posting this. It looks my freeze on start is finally fixed.

1 Like

It seems my problem isn’t fixed yet. I have been opening/closing Cubase for about a week without problems. But today it froze again on startup. After a reboot, it started up normally again.

The error is still showing up in my Windows logs. I have followed the steps to fix it. I changed the permissions for the registry keys. Changed the TrustedInstaller to my computer name. Afterwards I also did the DcomCnfg and added a Local account. Apparently I must have done something incorrectly. I feel like this error has to do with the Cubase freezing. But I’ll have to tinker some more to get the error message to stop and to figure out if this is really the cause of the freezing.

  • I have Cubase 12 Pro. In the Steinberg Download Assistant, it offers SpectraLayers One v8.0.20. I installed it. But I could not get it to work correctly. That is on Win10 on an old laptop.

  • Since I used to have Cubase 11 Pro (with the usb-dongle), I downloaded the previous SpectraLayers One v7. It works in Cubase 12 Pro and on my Win10. But I had to put the usb-dongle back in the computer, otherwise it was complaining about activating SpectraLayers.