Cubase 12 Pro hanging on initializing ARA Service scanning plugins

Out of the blue tonight Cubase 12 Pro hanging on initializing ARA Service scanning plugins. I have not had any problems until tonight and have not added any plugins for some time now. I did not see anyone else with this particular issue.
Any ideas?
Using Windows 10, Allen and Heath GSR-24m console,

This is happening on all versions back to Cubase Pro 10. Always hanging on the initializing ARA Service.


Make sure, your ARA plug-ins are up to date, please.

I had the same issue. I was on Cubase 10.5.20 … than 10.5.30 … than 11.0.41 always the same issue.
I read on a reddit, that it is some kind of dialoge problem with a second screen and the dialog could not be shown. But it seemed that was not my problem so it had to be something simillar but different. So I tried to open my iLok App but it couldn’t open. So I reinstalled it.
After reinstalling the app, cubase could load all the licenses without any further problems.
Everything back to normal.

I hope that might help you.

best wishes

1 Like

Great stuff, thanks a lot. Had the same inexplicable ARA Services freeze all of a sudden. Opened up iLok, noticed it required updates, went along with it and boom, problem solved!