Cubase 12 (Pro) not recording sysex when device is used by MIDI Remote script

Cubase 12 is not recording sysex data.

I’ve verified the device is sending sysex with MIDI-OX.

The MIDI Record Filter preference does not have sysex selected (i.e. preference is not set to filter sysex from recording)

Steps to reproduce:

  1. Launch Cubase 12
  2. Create a MIDI track
  3. Assign input device of the track to a MIDI device that can send sysex (e.g. a hardware synth)
  4. Start recording on the track
  5. On the MIDI device (e.g. the hardware synth), trigger a sysex send (e.g. a program dump)
  6. Stop recording
  7. Observe that no sysex is recorded

It appears the issue is with the new MIDI Remote functionality:

If a MIDI device is used for a MIDI Remote script then SysEx recording does not work for that device.

Steinberg support has acknowledged this issue and reported it to developers.


Couldn’t figure out why my Virus C wouldn’t dump sysex to Cubase.

Hoping this is the issue and I can just delete the MIDI Remote Script for now.

Sadly, this has not been fixed in 12.0.10

Still not fixed in 12.0.20

Still not fixed in 12.0.30. This has been driving me up the wall all evening. I KNOW my Montage is sending SysEx, but with local off, it’s not sending it back to the knobs in Multi MIDI I/O mode. It’s not even showing up in the MIDI Monitor insert.

I verified it’s definitely sending with MIDI-OX.

Steinberg, please prioritize a fix for this. You broke my Montage workflow in Cubase with this. I was very excited about the MIDI Remote changes. Now, I can either use them, or I can use my Montage as intended.

This sucks.

1 Like

Can we please get an update on this? It’s really screwed up my MIDI world.

HI I m expercieng this aslo , the SYSEX cant be dump , kindly adress this Issues with an uodate ASAP .


I fell for it again this afternoon, was losing my mind trying to figure out why my Montage knobs & faders weren’t working again, thought I had MIDI Remote already disabled but did not.

This is exasperating and infuriating. Please fix it already! Jesus!

Finally I found an answer to my problem… Well, not the solution unfortunately but now I know what the problem is. I have to stop using the MidiRemote for now.
@Steinberg, How about an explanation and solution on this…