Cubase 12 Projects randomly incompatible with Cubase 9.5


I generally use Cubase 12 (12.0.52 to be specific) and usually those projects open fine in Cubase 9.5 but sometimes it tells me “this project was created with Cubase 12.0.52, this program version cannot open it”.

I wonder if there is any way this could be normal behaviour. Is that something you can expect when making use of Cubase 12-Exclusive features, for instance?

I don’t use a lot of ‘special features’ so it would be pretty fuzzy to investigate whether I used a feature that isn’t present in 9.5 in the projects that don’t load, so I wonder if that’s a possibility at all.
I seem to remember that some time ago I just got some error messages that certain features can’t be accessed, but the project loaded fine.
That’s the way it ‘should’ be IMO. Wouldn’t be that cool if projects become non-reverse-compatible that easily.


My system info, if relevant

Microsoft Windows 10 Pro
13th Gen Intel(R) Core™ i9-13900K, 3000 Mhz, 24 Core(s), 32 Logical Processor(s)
128 GB RAM

Of course, it is normal. All newer versions introduced new features, that are not available in former versions.

Thats not their problem.
They cannot even open the projects. And not all of them are affected, so general version incompatibility seems not to be the issue.

According to the mods it should be possible to open those projects always. Be advised though, that there might be different outcomes according to timestretch, or other features which were not present in older versions.

I remember a thread with a similar issue in this forum, I am gonna check if I find it.

I doubt that.
It makes no sense to guarantee backward compatibility over more versions. 9.5 is more than 4 years back.

To make it possible that older versions can open all future project files without issues is an enormous effort that will hold back innovation and makes bug fixing nearly impossible.

None the less, Cubase is generally backward compatible (I suspect the OP has a fairly unique situation causing their problem). When you open a Project in an older version of Cubase any newer features or capabilities used in the Project but not found in that older version are just ignored & when you open it later in the current version of Cubase you can access them again - even if you saved it in the older version. For example if you have a C12 Project that uses Sampler Tracks it should open just fine using Cubase 8 (which I think is before Sampler Tracks were introduced) except all your Sampler Tracks will be missing. Now if you save that Project using C8 and then open it using C12 you should find your Sampler Tracks back in the Project.

A few years ago I tested this going back to the oldest version I had installed (Cubase 7 I think?) and it worked flawlessly.


True if they were just trying to build & maintain the compatibility on an ad hoc basis. But if it is designed into the architecture from the get-go, which Steinberg appears to have done, then it can be fairly straightforward. A Cubase Project is really only a data-structure containing all the information that the Cubase program needs to convert that Project into sound. Each element can be tagged with an ‘only use after… code’ kind of like the height signs at amusement parks. So Cubase 8 opens a Project created with C12 and comes across a bunch of entries defining Sampler Tracks. Each of those entries will be marked with a code indicating this data is only useful for Cubase 9.5 (or whatever) and later. So C8 simply ignores that data. It doesn’t do anything special to be compatible with Sampler Tracks - it just ignores their existence.

1 Like

When this occurs, does it happen in Projects which you could previously open in C9.5 fine - but can’t now? Or is it more like a specific Project never has & never will open in C9.5?

If you are using the Pro version of C12 have you tried using File>Import Tracks From Project… to pull them all into a fresh new Project and open that in C9.5.

Is there any pattern for which Projects will or won’t open? For example, Projects using ARA.

For SB it apparently does, as SB stated it officially some time ago and the mods also confirmed it multiple times that it is possible here on the forum.

They are not asking to open them “without issues”, they cannot open them at all.

Maybe you should read their post again.

After hours of investigation it seems to come down to the pitch shift process in the direct-offline-processing window. I narrowed the issue down to one track which contained such processing. After removing it I could load the project with just that track, but only after importing it into yet another project. If I only remove the pitch shift processing without importing track into a new project too it generates a “a serious issue has ocurred” message when trying to load the project in 9.5

The reason for that seems to be that the pitch shift data is still somehow stored in the pool, even after removing it. When importing it into a new project it doesn’t get imported into the pool of the new project, so it doesn’t become incompatible.

In another test I managed to solve the issue by deleting all pool references with offline-processing pitch shift data.
To be clear, this is pitch shifting with the module in the direct offline processing window in either the window with the keyboard or envelope.

Once that data is removed from the pool I don’t even need to import anything into a new project.
Although for that test I also deleted the track I tested most of the time, so the project was empty.
I guess that explains why even empty projects produced that issue - the pitch shift data still is referenced in the pool.

It also explains why I had to import the track into a new project despite removing the pitch shift module. The pitch shift data was probably still saved in the pool of the old project but was not imported into the new project because the module was no longer active.

I didn’t find a way to only remove the edits from the pool. Deleting the audio files isn’t removing the pool entries, that way I just get a missing files window. The pool entries + edits remain. I can only delete the whole audio event (in which case the event vanishes from the project), not just the edit entry.

This was insane to figure out and hopefully it’s understandable. Mostly for others in case they come across this issue, I don’t know if you want to dive that deep into it hah…

Kudos for even figuring out what was happening.

I also have a project file in which I replicated the issue. It doesn’t open in 9.5 but opens fine in 12.0.52.

Perhaps @Martin.Jirsak wants to have a look at it. Seems like projects are generally supposed to be reverse compatible.
Sending the project as a folder (which can be downloaded as a zip) so the audio file is being referenced. But it seems to even work without the audio file.

Btw, previously I said just removing the direct offline pitch shift wasn’t enough and the pool had to be cleared or the track had to be imported into a new project after the removing it, but in another test this worked too.