Cubase 12 - SuperVision Graphic Slow


i’ve tested Cubase 12 on windows with the same GPU card and supervision is smooth, but in my mac with the same processor and GPU card is struggling to work.

Thats not Supervision consuming resources, because GPU is only 6% loaded and CPU only 25%.

It seems Cubase is lagging because don’t use GPU. If i open a mixer console in a bigger window, the GUI will be also laggy like this video.

Why? On Windows Cubase works better than that.

i’m using cubase since 10.5 and it always happened in mac version.

I think it is a time to correct that. Logic don’t have this problem even Ableton, Bitwig.

i’m looking foward every update to see cubase running smooth.

Hi, I presume it slows down when the waveform display is zoomed to a certain size? If so I’ve heard from my friends @ steinberg that it gets fixed soon. Cheers.

But it doesn’t make sense, just see the video and you will see that isn’t smooth enough like oszillos megascope. I’ve changed the zoom in and out, the problem persists.

In windows the supervision so much better than mac. It’s a problem because cubase don’t use the GPU in any way. I have this problem when mixing with a mixing console open in a full screen window, or using two screens. Don’t matter what i do, cubase when need to use graphic card processing it slow down and the fps of all meters are affected, also the play cursor on the track.

I don’t know what steinberg is doing about it, but it has to be done as quick as possible. We are in 2022 and there is a company launching GPU audio. Why the VST creator is so slow on getting better performance? Ableton is always patching and bugfixing his software, cubase make 1 release per year and 1-3 bugfix and charge a lot for any update, that don’t bring a lot of new features. I prefer performance than new features at this point. I would like to see my projects running smooth enough with many graphics i want in supervision. And yes… i’ve notted that steinberg reduced the quality of supervision graphics supervision in cubase 12 just trying to make it more stable. (didn’t work)

I have a AMD Randeon 5700 XT 8GB - Its a superb GPU and works like any other on Cubase. Don’t make sense getting lag graphics with this GPU in any way.

Cubase is a good software, very very good and i love it. I just want steinberg make a better software and fix the software while we are paying per year for little fixes and some news, but the old problems persists.

if you want, i do free technical tests just to get this graphics functionality solved. Everyone is affected and its a shame to see some Cubase lags in the mac. I see it in every video on the youtube, even in CUBASE oficial channel, check that:

(after changing the preset, supervision start to lag)

When steinberg will talk about it? Why don’t use GPU. Its because the software runs in java or something like? lets build together, lets do better, lets do what producer wants. I want to produce music and don’t want to write in forum about problems of my DAW and why my expensive GPU handles all of the newest games, graphic apps and don’t handle 700mb of software called Cubase.

1 Like

Cubase is using the GPU to render it’s UI. Do you have by any chance disabled GPU support in the preferences?

If it is using the GPU, then it still does not explain why there are graphical performance issues all over the place, specifically when the Lower Zone Editor is opened, with the new issues related to Smooth Waveform Drawing introduced with Cubase 12, and when multiple events are selected and the display modes are set to Show Clips and Events + Show All Clips.

I don’t know about Mac, but here on Windows I am talking about severe performance drops when editing audio, this is not just a slight slowdown, the whole DAW here is getting refreshed at 2 or 3 FPS !

I have made a whole post about it. A short video shows the performance issue with the bug related to Smooth Waveform Drawing only, but it also does this when multiple events are selected and displayed in the editor, and the two can also combine, just making things even worse.

The issue is extremely serious !

That said, when graphical performance issues are occurring, this is the CPU usage that increase, and not the GPU, just like if there was some sort of bad coding, like an instruction that is caught in a loop, or bad communication between CPU and GPU.
Issues like this should never occur, or at least not that easily !

Also Cubase is still stuck to 60 Hz frame-rate in 2022 !
What about allowing it to refresh at higher rates for those who have 144 or 240 Hz monitors ?
Just saying that high refresh-rate monitors have been around for many years now, it should be time to wake up !

That should not be very complicated, just add either a setting in Preference where we can choose Cubase max frame-rate, or just make it automatically adapt to the monitor…
If Cubase is really using the GPU, then this should not be a problem to unlock the frame-rate.

1 Like

@Arne_Scheffler No, its enabled. I’ve already test with and without this option and the problem persists.