Cubase 12 "unrecognizes" Nektar MIDIFlex 4

The MIDIFlex appears to operate normally when the USB connection is made to my MacBook Pro, with green lights indicating the active status for MIDI ports 1 & 2.

When I open Cubase 12, at some point, the lights for both ports change to red, and no MIDI information makes it into Cubase.

The Nektar is recognized and fully functional in Audio MIDI Setup, and both input ports show up as available inputs for Cubase MIDI and instrument tracks, but no MIDI is being received through the interface

Hi,

Isn’t there something like a sleep mode on the hardware by any chance? Doesn’t the device become disconnected after some time automatically?

No sleep mode. The interface shuts down within seconds of firing up Cubase 12.

Hi,

Could you try another USB port am cable, please?

If you are using Logic 10.7.9 and you are setting up your Nektar controller for the first time,
you will need to connect your Nektar controller AFTER Logic is already running. Once you have done that, quit Logic. Then with the controller still connected and powered on, open Logic again.

Link to support page: NEKTAR SUPPORT 2 - Nektar Technology, Inc

The only information I could find about the led colors:

Automatic port detection: Even better, MIDIFLEX 4 also automatically detects if a MIDI In- or Output is connected and displays the setting with its MIDI port LED indicators. So just connect your external MIDI gear and let MIDIFLEX do the rest. The 4 LEDs indicate if a port is configured as In- or Output.

From the support pages MIDI Communication Issues - Nektar Technology, Inc :

Summary

Troubleshooting

If you see messages appear in the monitor window in MIDI Ox or MIDI Monitor, as you press keys and move controls it means that data is being received. If that is the case, quit MIDI Ox or MIDI Monitor and open your DAW/music application, then check if it will respond when you press the keys or move controls.

Often music applications will have a MIDI activity indicator which will move or light up when incoming MIDI data is received. If you don’t see anything like that, check that the MIDI settings in the application are configured correctly. See the Setup and Troubleshooting pages for the DAW and controller series which you are using, for details about configuration.

In Windows only one application can access a devices MIDI ports at a time. This is the cause of most of the MIDI communications issues which we encounter in Windows. Most of the time, this kind of problem is caused by having two music applications open at the same time. In those cases, you can simply close your music applications, and open the one which you would like to use with your Nektar controller first.

However, there are some applications which run in the back ground or are not obviously compatible with MIDI devices, so it’s not as easy to tell that there is a problem. For example, the control panel software for some Audio interfaces can be controlled via MIDI, so they can grab MIDI ports as your computer begins to start up. Also, Google Chrome has MIDI extensions, so it is recommended to make sure that Chrome is not running when you try to start your music applications.

1 Like

This is a Steinberg forum. I’m using Cubase 12. Thanks…