Cubase 12 Upgrade ASIO-Guard Issue

@Jorge_Ruiz , I did exactly the same thing last night, and got a similar Visual C++ message when i updated Waves Central. Immediately after that i got the “very old- looking” dialog window i described a post or two above.

This is all in Cubase 11 Pro, but I believe something was changed there by Steinberg without my asking for it (my C11 Pro license description in the USB eLicenser now having new words appended to it after updating the eLicencer, something like “not upgradable”).

So i don’t know if it was a C12-driven change (i didn’t want anything to do with C12 “in my house”!), or that C++ Visual thing you mentioned.

I am trying hard to keep from moaning and whining, “Why couldn’t they just let me use my C11 Pro without introducing c12 issues??”.

I need to try harder, it seems! :smile:

1 Like

In fairness those .net distribution packages are included in a lot of plugins too (in fact they are in a lot of software packages that are nothing to do with audio as well). So they could have come from ilok or waves or any number of developers. I usually do not install the .net part when I see them come up and I go and get the latest .net versions myself. Often when installing an older plugin some really old .net can get installed messing things up.

1 Like

I’m in a Mac and this is an issue for me … I’m not sure it’s windows specific … ?


I’ve been running Cubase 12, Win 10 (latest) and UAD Apollo x6, and encountering the issues listed above, in that Cubase 11 projects that played fine in C11 wouldn’t play in C12.

Changing ASIO guard to “high” and clicking the check box for “Activate Steinberg Audio Power Scheme” cleared the trouble for me. Take it for what it’s worth.


Hi. Same here. Cubase 12 - noticed when the ASIO Guard is on and I close key editor during playback I have a dropout. With ASIO Guard off everything is fine. PC - MB ASUS, CPU AMD Ryzen 7 5700G, 32 GB RAM, Windows 10 Home. Checked with my Cubase 11 installed on Windows 10 Pro on MacBook Pro 13" mid 2012. No dropout whether ASIO Guard on or off. Audio interface with both setup RME FF400. Buffer size doesn’t change anything.

1 Like

My experience has been this: with ASIO guard on I was getting glitches as I shifted focus from track to track (i.e. selected different tracks). I went into preferences and under “Project & MixConsole” I disabled “Enable Record on Selected Midi Track”, “Enable Record on Selected Audio Track” and “Enable solo on Selected Track”. Now I can select different track while playing without getting those hiccups.

This makes perfect sense, by disabling the record function, the tracks are not armed when you select them. But, do your glitches/hiccups return when you manually engage the Record button on/off?

1 Like

I can enable track monitoring or record without glitching but when I disable either it glitches. Sometimes just a minor audio pop but other times an actual hiccup in both audio and the GUI and at least once the track stopped playing back.

Yes, that’s a similar issue to what I’m experiencing as well. But, I haven’t had a track stop playing back - yet! From all the other user experiences shared here, there does seem to be some issues with C12. Let’s hope this thread helps Steinberg narrow down the causes and provides a fix on the next update!

Same thing here. Performance doesn’t only seem to be worse than CB11, but very “unstable”. It’s random to me, I can’t seem to make something out of it. Sometimes it’s decent, sometimes it’s unusable even in an empty project.

  • System information:
    – Apple Mac Mini with M1 Chip, 16GB of RAM
    – macOS Monterey 12.3 (21E230)
  • Project Details:
    – Sample Rate: 44,1
    – Asio Guard Level: Low, Normal, High: Normal
    – Audio Buffer size: 256 Samples. That said: Changing the buffer size above 256 makes almost no difference, which is very weird.
    – number of VSTi/ Audio/ Midi tracks: 32 Audio, 15 VSTi, 15 FX Channels. So not THAT much of a big project.
    – VSTis in the affected project: AmpliTube 5, Serum, Diva. Some UAD stuff, some FabFilter stuff

CB12 of course running in Rosetta mode.
That same projects runs fine at 192 Samples in CB11. CB12 will not play it at 192 Samples.

1 Like

Same Problem: Playback of whole project works fine. But live playing with single instrument tracks causes audio dropouts and cpu spikes. Also when switching between tracks.
Dropouts also occur when using some cubase plugins (not only external plugins), for example multi tap delay.
i7 12700K, 5Ghz, 12 cores
32 Gb ram
Windows 10 64 bit Pro
Samsung Evo Pro M2 SSD

1 Like

I am finding Cubase 12 very erratic and unstable lately. When playing a song and I’m flipping between tracks making changes, or even expanding an automation lane I’ll get a freeze or crash of the App.

It makes me nervous working in this version where I have to constantly save.

1 Like

Same win 10,crashes and pops and clicks ,upgrade from working 11

has anyone tried the korg wavestate native or opsix native demo plugins?ive just installed them and it kicks the crap out of c12 but ok in c11 and ableton ive 11 lite.
i had one instance of it going asio meter went to max and started glitching,i opened the plugin and created a patch using only 1 lane the asio meter dropped to 75% …i then opened opsix played one sound it maxed out then crashed.

1 Like

update in c11 the asio meter isnt going a quater of the way up with same project.

Posted this in another thread already.

Tried the recommendation of disabling Hyperthreading AND changing the system performance from “background services” to “programs” and I got around 10% difference on vst performance meter.

I’ve tried before disabling the HT option but there was no difference, so I suggest for anyone who wanna give it a try doing both.

1 Like

You all helped immensely to narrow the issues down, indeed!
@djn14 , @Sparqee : As for your click-on-rec-disarm bug: there’s no fix yet, but a workaround. Briefly, the clicking appears, when the Asio Guard buffer has the same size as the audio interface buffer. To avoid that, you can e.g. chose AG low with anything <256; AG Normal with anything <512, and AsioGuard High with values <1024. Please let me know if this helped with your specific issue.

The stuttering/ heavy dropouts when playing record-armed VSTi tracks is a different thing. This happens on some intel CPUs and we need to readjust our audio engine to get rid of this bug. This issue is prevalent on systems with a medium number of CPUs (12 … 32), as far as I can see from your info, and is present for low latencies, like 32. 64 and 128 samples. You could try raising the buffer to 256 or 512, for now. We are working on a solution for this.


same issue here have to max out everything to get it working smooth . With cubase 11 i had low settings no issues even with high demand files like the demo they provided.

1 Like

Hi Chriss,

Just to let you know, I’m experiencing stuttering and dropouts even without arm-recording any track.


1 Like

Hi, thanks :blush:, which Intel CPU?