Cubase 12 Upgrade ASIO-Guard Issue

  • Windows 10 (ver. 19044.1586) 21H2

  • Intel Core i9-7940X, 3.10GHz, 18 cores

  • NVIDIA Phoenix 1060G Graphics Card

  • C12 Always Has Dropouts, especially when adding effects plugins

  • 48Khz, 24 bit

  • Asio Guard - High

  • Audio Buffer - 1024

  • Any number of tracks, of any type

  • Kontakt (turned Multiprocessing both ON and OFF, C12 still has Asio Guard spikes)

1 Like

Just adding my input, I am also seeing random Peaks in Cubase 12 in the performance meter in an empty session, that is not present in Cubase 11
48k 32bit | Asio = Normal | Buffer makes no difference for these spikes

Windows 11 | i9 12900k | 64g DDR5 | 3090 | Quantum 26/26 | Focusrite 18i20 3rd Gen

1 Like

It’s not our job to debug their software.
I’m still unable to use the software.

Has Steinberg said they’re working on a fix :face_with_diagonal_mouth:

1 Like

I learnt that for some, the redesigned Performance Meter is leading to the impression that C12 is struggling more with processing load, than was C11. This is not the case - with exceptions discussed here.
Our investigations here refer to audible performance issues with C12, where C12 is failing to playback the projects dropout-free, which played just fine in C11. Please consider when posting :heart:.

Just some remarks on the Performance Meter:

  • the redesigned Performance Meter in C12 is showing four values, aiming to give users a more detailed info about the system’s momentary load:
    Realtime: how much of the available time (in % of the real time latency, set by your audio buffer size) is consumed by real time processing? This value is averaged over several buffers, and therefor moving slowly. It gives an impression of the overall load of time-critical processing in your project.
    Asio Guard: how much of the available time (in % of the Asio Guard latency, set by the Asio Guard level Low/ Normal/ High) is consumed by prefetched (= non-real time) processing? This value is averaged over several Asio Guard buffers, and therefor moving slowly. It gives an impression of the overall prefetch load of your project.
    Peak: this value shows the recent maximum values of the time-critical processing; it gives an impression if there are load peaks, caused by - e.g. - certain instruments, song structure (plenty of Midi notes starting at the same time,…) or FX. This can help you find and omit certain bottle necks.
    It is not averaged, and can therefor look jumpy, especially with small real time buffers. It also reflects the jitter of your audio hardware. A heavy jitter can limit the performance with small buffer sizes.
    Disk Cache: showing the read/ write buffer fill level, referred to the max. throughput (you mostly only see it move on cursor relocate or playback start)

I did consider greatly before posting and merely added my input to the reduction of performance compared to CB11 before even adding anything to the session. My post was to outline that there is obviously something unoptimised going on in the CB12 engine compared to CB11 and therefore concluding that these issues might be related. For example in the most basic sense if I am having peaks spikes before filling a session with instruments then these peaks will eventually cause drop outs and this is why I posted my input here on this forum, so again one did consider the topic and the relation of that topic to ones own experience. One is now going to make a cup of tea…


Sorry - my post was not meant as reply to you personally :face_with_hand_over_mouth:. (I seem to struggle with the Reply button…).
When coming back from tea - could you please let me know which Asio Guard level and Audio interface buffer size you are deploying? That info is very important to us. Thanks!

I will expand to help:

  1. First of all these peaks are very small but random and not present in CB11, I can see that they may become a problem during a large session
  2. ASIO guard level is currently at Normal but the peaks can be reproduced on all 3 asio settings including off.
  3. I have experimented with a Thunderbolt (Quantum 2626) and a USB Audio device (18i20 3rd gen) and the random peaks remain
  4. I have experimented with 2 Buffers 256 and 512 making no difference
  5. Session is in 48k 32bit
  6. My issue is not important compared to the other posters and I do not wish to divert resources, my original post merely serves as an observation to what I am seeing before starting to populate a session, the spikes are very small, quarter of a bar at worse but I can foresee as a session builds it might translate into being more problematic.

Cheers and I hope it helps


Could you please all reply to my post here and list:

  • System information:
    – your OS platform (Apple Intel, Apple Silicon, Windows)
    – your OS version number (like Win 10.1809, macOS 11.6.4,…)
    – your CPU model and number of cores
    –NEW: your Graphic Card Model
    – does C12 always fail ? Or just from time to time?
  • Project Details:
    – Sample Rate
    – Asio Guard Level: Low, Normal, High?
    – Audio Buffer size
    – number of VSTi/ Audio/ Midi tracks
    – VSTis in the affected project
System information:
–  Windows
– Win 10.21H1
– CPUIntel(R) Core(TM) i7-3930K CPU @ 3.20GHz 6 Cores
– GPU AMD Radeon R7 200 Series Primär/Diskret
– C12 works fine when mixing, when recording/monitoring often leads to peaks and drop outs,

in the windows ressouurce monitor one instance of amplitube 5 vst3 leads to the effects and uses
more than twice the cpu as the same project in cubase 11.

Project Details:
– Sample Rate 44,1
– Asio Guard Level: Low, Normal, High? (occurs in all 3 levels)
– Audio Buffer size (256 and others)
– number of VSTi/ Audio/ Midi tracks (one instance of amplitube 5 is suffient to generate the peaks
– VSTis in the affected project
1 Like

If the problem seems to occur with 3rd party plugins it would make more sense if people would try with and without these 3rd party plugins. Then add them back to narrow it down.

Hi Chriss,

Thank you so much for joining the discussion! I very much appreciate your attention and dedication toward helping discover the root cause of the issue we are experiencing.

Moving forward, to assist in the further investigation, I hope all users experiencing issues and participating in the discussion will provide the detailed information you have requested.

Here is my detailed information:
– OS platform = Windows 10 Pro
– OS version = 21H2, 19044.1586
– CPU = Intel Xeon CPU E5-2687W v4 @ 3.00GHz 3.00 GHz (2, 12 core processors, )
– Graphic Card = Nvidia Quadro P600
– does C12 always fail ? = Yes

Project Details:
– Sample Rate = 44.1, 24 bit
– Asio Guard Level: Low, Normal = audible dropouts / High = I do not hear the dropouts
– Audio Buffer size = 512

– number of VSTi/ Audio/ Midi tracks
– VSTis in the affected project
Complete list available in C12 Demo project = “C12 Demo project = “Cubase 12 - Pop Demo By Austin Hull.cpr_MIXED””

1 Like

This is a compilation of my experiences.

  • System information:
    – your OS platform: APPLE INTEL
    – your OS version number: MacOS 11.6.4**
    – your CPU model and number of cores: iMac Pro 1,1 3 GHz 10-Core Intel Xeon W
    –NEW: your Graphic Card Model: Radeon Pro Vega 56 8 GB
    – Does C12 always fail ? Or just from time to time?
    • At first the problem rendered C12 unusable. I had random spikes even in empty projects. The frequency of the spikes increased if I loaded instruments like Kontakt, Omnisphere, Halion, etc. C11 projects that ran without issue with these same plugins now have issues. I can’t export mixdowns because the export stops because of CPU overloads. Even at idle with one track and pad shop as the VST, I’d eventually (within a minute) get a random CPU spike that pegs the red indicator. If I add more VSTs, it happens a lot more frequently. PROJECT DETAILS: 48khz/32bit, ASIO at Medium, 512 buffer, audio priority boosted, 4 sec preload
    • I also opened an empty project in C12. Added one track with Padshop 2 + a ModMachine plugin. Crazy, random CPU spikes all over the place. I then did the same thing in C11. No problems whatsoever. All settings (ASIO Guard, boost, buffer, audio interface, etc.) are the same in the two projects. PROJECT DETAILS: 48khz/32bit, ASIO at Medium, 512 buffer, audio priority boosted, 4 sec preload
    • I then created very simple 1 track project. Added a VST instrument. Added an effect. I had CPU spikes all over the place. I saved the project. I opened the exact same file in Nuendo 11.0.41. The file played with NO hiccups, spikes, etc. PROJECT DETAILS: C12-As above. Nuendo - ASIO Guard is normal, audio priority is normal, disk preload is 2 secs, 32 bit float processing, 512 buffer.
    • At one point I just completely shutdown and restarted the machine a couple of times. (I rarely turn my machine off.) When I restarted C12 and opened a previously problematic project (with 6 Kontakt instances, no plugin multi-processing), it worked! I left it playing/looping overnight to see if any CPU spikes would be recorded. The performance meters did not register a single spike overnight. I ran the project with all tracks record enabled. No issues! PROJECT DETAILS: 48/32, ASIO is normal, audio priority is boosted, preload is 2 seconds, 512 buffer.
    • Unfortunately that was short lived. I started a new project in C12. I didn’t get very far before the random spikes started happening again.

** - CURRENT SITUATION: All of the above happened while running Big Sur 11.6.4. However, Apple released a point update to Big Sur. I performed the update. I am now running 11.6.5. The random CPU spikes and related issues are not happening for me anymore, and projects that were formerly spiking are not. .I’ve tried creating simple projects using VSTs like Padshop, Omnisphere, and Kontakt and I have not hit a random spike yet. I have no idea whether or not the OS update is related to the lack of issues, but there you have it. (Note that, I have run across a different problem with Aggregate devices. I posted about that as a separate topic in the forum.)

  • Project Details: Included in the above descriptions.
1 Like

My current project:

  • System information:
    Windows 11 Pro
    21H2 Build 22000.556
    Intel i9 12900k 16 Cores (8P + 8E Cores)
    NVIDIA Geforce GTX 1050 Ti
    Cubase fails always

All projects work fine in C11, no glitches, no stutter, no droupouts whatssoever.

  • Project Details:
    – 44,1
    – Asio Guard Level:
    – Audio Buffer size:
    64 samples
    – number of VSTi/ Audio/ Midi tracks
    7 VSTis (+ 1 external VSTi, Waldorf M)
    26 Audio tracks
    13 FX
    15 Groups
    2 MIDI tracks

– VSTis in the affected project
Repro 5
Blue 3
2x Superior 3 (1x as track instrument and 1x as rack instrument)
The offending VSTi is Superior Drummer 3 (the rack instrument)

1 Like

Does this help in SD3?

I had the problem of CPU overload causing major audio glitching when running a single audio track and one VST effect (Helix Native or Amplitube 5) on Win 10 PC, i9 processor. Solution turned out to be simple. Just had to activate the Steinberg Power Scheme in Studio Options. This is set to off by default in the update and the setting does not get picked up from the preferences. Certainly worth checking if you have this problem.


DUDE, you’re a damn genius. IT WORKS FOR ME! No more dropouts!

But seriously?? Activate Steinberg power scheme?? That’s what the whole thing is tied around to?? What’s up with that??

Besides, I’ve already manually disabled all power-saving options in Windows Settings itself. So this quite stumps me.

Anyway, props to ya, thanks so much!

1 Like

It permits your computer to operate at full power.

Lol, I know that. But I’ve already manually disabled all power-saving options (USB, PCIe, etc etc) in Windows Settings itself. Not sure what else the Steinberg power scheme could add to that.

Something you missed? Have you compared the power plans in Control Panel\Hardware and Sound\Power Options\Edit Plan Settings>Change Advanced Power…

Yep, I have. Everything manually disabled. I check after every Windows update as well.

Oh well, I guess Steinberg power scheme has its own ingredients that’s not seen in the Advanced Power Settings in Windows. Either way, I’m glad I can start using C12 now. Won’t delete C11 yet still though, just in case.