Cubase 12 Upgrade ASIO-Guard Issue

What about CPU speed?

C-states and Speedstep is turned off in the BIOs.

1 Like

Big thanks to @Andrew_Norman for figuring out the Steinberg Power Plan as possible difference to your C11 installation! This setting doesn’t get transferred from your Cubase prefs to the new C12 prefs. We should consider to enable the scheme by default, as power saving profiles become dominant. When you close Cubase, the power plan is reverted back to your earlier settings, so no worries about wasting too much energy.
Thanks also to all of you sending in your system and project setups! That was very helpful, too. So far, it looks like only Windows users are affected by the dropout/ overload issue. The only macOS system reported was solved after the update to macOS 11.6.5 (please correct me, if I miss something). There were also no settings/ instruments/ plugins/ graphic cards/ system properties which all of you had in common. This also lets me hope that most of you will be fine when activating the Steinberg Power Scheme.
I hope you can now enjoy C12!

3 Likes

Thanks Chriss for the update.

Unfortunately for me, activating the Steinberg Power Plan has no effect on my issues. I have tried both with the power plan on/off, I still get an audible dropout, when ASIO-Guard is set to Low or Normal. When AG is set to High, I don’t hear the dropouts (they may still be there, but I can’t hear them).

Steinberg power plan has been activated from the beginning. Strong peaks and dropouts (see above)

2 Likes

That is very interesting, in that when i compared Steinberg Power Scheme to my manual changes in Device Manager, they were quite similar.

I wonder why Cubase responded differently …

1 Like

Unfortunately not, as I have SD3 set that way already.

While that is always a good idea, it doesn’t apply in my case. That setting changes Windows power-scheme settings only if you haven’t done that manually already. Since I already set the Windows power-settings when installing Windows, the “Steinberg power scheme” doesn’t do anything on my maschine.

1 Like

Sorry, not over here. It doesn’t matter if the Steinberg Power Scheme is on or off, the problem remains.

BTW: That setting doesn’t make any difference in C11 neither.

That means it’s an Cubase issue, no?

Come on guys, there is certainly something that you have changed from C11 to C12. It shouldn’t be that hard to figure out what it was.

Also keep in mind that switching away from a heavy spiking track to - say - an empty track has a huge delay and unloading/reloading VSTs (according to the CPU meter, but also audible, some effects are just gone for a second and come back).

I think I have mentioned that numerous times in this thread and there is no way that is related to the power scheme. That’s certainly a Cubase issue.

2 Likes

Ok… the power scheme does the trick for some, but by far not all of you.
We’ll dig deeper tomorrow. Will keep you updated. We are working hard on this.
Cheers
Christina

3 Likes

Thank you @Chriss!
Appreciate your continued attention and hard work. Looking forward to your updates.

1 Like

I’m waiting for an update as can not use software 11 was fine
tried all steps that might help, no joy
Ryzen

Thanks Chriss!

I definitely agree with you. This is why I was very surprised that the power scheme thing worked for me. I still don’t really believe this has anything much to do with the power scheme.

Either way, even though C12 runs smoothly for me now, I’ll also still be waiting for an update.

Sorry, don’t know what SD3 is but I think it’s worth activating the Steinberg scheme no matter what changes you have already made in Windows, if for no reason other than to remove the possibility that the Steinberg set up in C12 is doing something other than that which you can do manually?

PC:
I7 8700K, 32GB RAM, SAPPHIRE NITRO+ Radeon RX 580 8GB GDDR5

  • no hyperthreading, C-state inactive
  • Win11 (x64)
  • Win11 is configured for backgroud services, power option set to off
    Audio Interface is a UR824
  • activating the Steinberg Power Scheme doesn’t change anything

I’m working mostly with 96kHz - Buffer size is from 64 to 256 (depending on the processing needs)

I face the issue especially with HALion 6 and Goove Agent 5 and Amplitube 5. No matter if multi processing is switched off or on in HALion or Groove Agent 5.

The peak load is mostly near to maximum and I can hear audio drops/interruptions.

best regards
Werner

1 Like

System information: Apple Intel
OS: macOS 11.6.4
CPU: 2.6 GHz Quad-Core Intel Core i7 , 4 cores 8 threads
Graphics: Radeon Pro 450 2GB
The performance is terrible… 90% time laggy not usable for mixing. I re-opened in Cubase 11 for the same project it was smooth. I found that after update the license for cubase 11 no longer valid. I can’t even fallback to use cubase 11. (This issue resolved after I run maintenance on eLicenser again. Hope the project has no issue on fallback to cubase 11)

Sample rate: 48kHz
Asio Guard Level: was Normal in Cubase 11, changed to High in Cubase 12 and still lagging
Audio buffer size: 1024 samples
Number of VSTi: around from 6 to 20. No matter they all lagging in cubase 12
Plugin: not limited to but have Halion SE, Amplitube 5, NerualDSP, Addictive Key, Komplete Kontrol, Massive, ezdrummer

Steinberg please give a quick fix for this ASAP it made me unstable to do almost anything meaningful in cubase 12. It’s a BETA quality program with serious design issue. Steinberg is the one who developed VST and cannot assume VST developers do not perform what they can perform.

Edit: I checked my HALion and Multi-Core option is OFF already. I don’t have any konkakt plugin as far as I can remember, I use komplete kontrol sometimes as a container for other VST plugin sometimes for massive only. But I do not know if other VST or VSTi will use multirprocessing. I tried to switch off the ASIO guard, the small 6 track project back to smooth state, the large project around 20 tracks won’t run at all… even set to 2048 samples it still sometimes get 100% realtime and sound start lagging. Probably I’ve to freeze more tracks… But my project is still not into mixing stage yet and basically there is no inserts except amp sims on audio tracks.

1 Like

I always have the Steinberg Power on. On or off, no difference. Also I have no VSTi running at all. Just a lot of audio tracks. They run in C11, not in C12.

1 Like



Hi Chriss
attached you find two screenshots of the windows ressource monitor.
They are both taken from the same cubase project running
one with Cubase 11 and the other with Cubase 12
The project contains one instance of Amplitube 5

It seems interesting that Cubase 12 needs about twice the ressources AND the MSMPEng process seems to use much more ressources when Cubase 12 is running (I guess this is microsoft malware protection)

2 Likes

I am running CB12 on M1 and I opened a session last night mixed in cb11 that won’t even play in CB 12! The session stutters and the asio gaurd meter spikes and pins! Buffer is set highest setting asio is normal!

2 Likes

Just see that you are on macOS 11.6.4. Did you see gesslr’s post?:

Maybe that also does the trick for your system?
Cheers
Chriss