Cubase 13.0.21 maintenance update (Windows only)

I have not looked up on google but what we mean by glitches here are erroneous parts of the GUI that momentarily appear and disappear for no apparent reason. For instance: fast flickering, half-rendered buttons when mousing over, parts of other applications being rendered within Cubase.

The example with the folder here looks more like a bug to me, as it is neither momentarily nor totally erratic. Note that I cannot confirm this is bug for now.

Since there are so many issues with Cubase 13, are we able to inform us when is there a proper big maintenance update to resolve majority of the issues?
Im personally having a hard time with the instrument tracks and its channel and the selection of them…extremely buggy and quite disappointing :frowning:

When C13 was released, for me as for many, it was a disaster that should never have been released, and, in a few posts, I made my opinion clear. It was unstable - white screens that rendered interaction with the program impossible such that I had to use the Task Manager to kill it, video glitches (blank spaces where buttons should have been), having to “wash” the mix consoles with the mouse to get them to redraw, etc, etc. The .20, wasn’t much of an improvement.
Then the .21 update came out and, voila! Cubase at last works as it should have when it was released in November.
HALion makes a strange beep when it opens, you’ll hear it, which is odd as my system won’t record the output of Cubase, so it seems to be generated by Windows, not Cubase.
Therefore, even if Cubase still doesn’t work for you, the devs must be doing something, and hopefully, everyone’s bugs will be eradicated. Just let not any new ones appear in the process!
Video (1440p HD) of Cubase:

1 Like

A post was split to a new topic: Cubase 13 hangs when scanning VST plugins

I’m just gonna say it: Cubase 13 is a travesty and a black mark on Steinberg’s reputation.

It should never have been released like this. It’s honestly awful.

2 Likes

On Windows 11 Pro with Cubase Pro version 13.0.21 the VSTI plugin like groove etc from Steinberg still sparkles (scintille)! Your Hot line takes too long to respond to us. I’m starting to regret having bought the Cubase 13 update.

Just for the sake of a balanced view, I am on Windows 11 AMD Ryzen 7700X 32Gb RAM Nvidia GTX 1050i using a 3440x1440 Ultra Wide Monitor with a Samsung SSD 980 Pro 2 Tb and this has been the most stable release of Cubase for me in a very long time.

Rock solid from the get go , and I’m even starting to get used to the lurid colour scheme :face_with_hand_over_mouth:

3 Likes

… and to add more balance: no issues here either, just using Intel integrated graphics.

I’m reasonably sure I’ve worked out the source of the freeze when opening plugins, for my setup at least. It’s MIDI Remote. I disabled the script I’m running and no more lag. It appears that MIDI Remote is doing something intensive when a plugin is first in-focus, especially if, like mine, there are MIDI bindings to the plugin’s parameters. Once it’s finished whatever it’s doing, usual operation resumes.

So, to be clear, in my instance it had nothing to do with the 13.0.21 update at all; the update just happened to coincide with activating the MIDI Remote script.

I’m going to start a new thread on this to check if anyone else is seeing this behaviour, if one doesn’t already exist, to start working out if it’s the script I’m using that’s responsible for it or something inherent with MR.

Therefore, out of interest, are you running a MIDI Remote script, and if so, does the freeze behaviour disappear if you disable the MR script?

1 Like

Having said all of that above, I have found a weird behaviour I’ve never seen before.

The audio clip highlighted is missing some of the waveform. I can hear the audio, and in the editor I can see the hitpoints, just no waveform to speak of:

Ohhhhh, this sounds really promising , i will give this ago as i do have the MR open on a 3rd screen constantly , but from what you are saying this ties in with all the lagging behaviour with MR in certain cases .
So the all singing and dancing shiny Lego toy isn’t so shiny and Steinberg will most probalby say " if you want to use your remote ? Suck it up "

I wish check after coming out of hospital in 5 days hopefully , sorry i can’t tell you right now

I don’t use any Midi Remote but I do always get the Freeze on all my ARTURIA VSTi’s (V Collection X) when loading the plugin UI for the first time - it’s fine if I close and re-open the instrument again in the same session.

I don’t get any freeze on other developers plug-ins. e.g. I get no Freeze on EastWest Opus, Steinberg Groove Agent or AKAI MPC Beats - nor ony any Plug-in FX

Wait… you’re on the forum while also being in hospital??

image

That’s outstanding! You should get Post of the Month or something.

You’re right, though, what to do about the control surfaces now? Not using them is not an option, but I can’t stand the lag every time I open a plugin. Hmmm… at least I can go back to using Mackie Control while MIDI Remote continues to develop, so long as Steinberg doesn’t discontinue featuring MC in the meantime…

Hope you’re on the mend soon.

Ah well, you , my Card says a Devoted BASIC , if you can work that one out lol
I think it was mentioned in C12 but can’t remember , It’s annoying for sure , very up professional having your graphics HALT for 1 second each time

I’ll look for mentions of it and check for any solutions - there must be users out there who are also experiencing this issue, and hopefully there’s clever ones who have worked out what’s going on.

You’ve definitely been part of the forum for long enough! In case you haven’t seen it, here’s the check list for getting to Level 2 status:

There must be one/some of these criteria you haven’t hit yet. Check out the Activity tab in your profile to see what it could be.

But, if you’re sure you’ve nailed them all, it may be worth getting in touch with @system.

I’m taking the risk of sounding repetitive here, but here’s the copy/paste issue I mentioned a few days ago

Anybody noticed that? It’s pretty annoying…
And this happens on Windows as well as macOS
(I tried on 3 different computers: two PCs, one Macbook Pro)